# CVE-2026-40162: Bugsink affected by authenticated arbitrary file write in artifactbundle/assemble

> Authenticated attackers can write arbitrary files to the server via the artifact bundle assembly flow in Bugsink, potentially leading to code execution.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** GHSA-8hw4-fhww-273g, PYSEC-2026-2404

## What is CVE-2026-40162?

CVE-2026-40162 is a high-severity vulnerability in bugsink, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Bugsink is a self-hosted error tracking tool. In 2.1.0, an authenticated file write vulnerability was identified in Bugsink 2.1.0 in the artifact bundle assembly flow. A user with a valid authentication token could cause the application to write attacker-controlled content to a filesystem location writable by the Bugsink process. This vulnerability is fixed in 2.1.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-40162?

3 open source packages ship an affected version, including bugsink. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bugsink` | PyPI | From 2.1.0 | 2.1.1 |
| `bugsink` | PyPI | From 2.1.0 | 2.1.1 |
| `bugsink` | PyPI | From 2.1.0 | 2.1.1 |

Products: Bugsink Bugsink.

## How do I fix CVE-2026-40162?

Upgrade bugsink to 2.1.1 or later.

## Is CVE-2026-40162 being exploited?

There is no known exploitation of CVE-2026-40162 in the wild and no public exploit code.

## Other vulnerabilities in bugsink

- [CVE-2026-27614](https://insights.sbomify.com/CVE-2026-27614/): Bugsink is vulnerable to Stored XSS via Pygments fallback in stacktrace rendering (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40162 and fix it if it is affected.

What it is: CVE-2026-40162 is a high-severity vulnerability in bugsink, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40162 in the wild and no public exploit code.

Affected packages and fixed versions:
- bugsink (PyPI): affected from 2.1.0; fixed in 2.1.1
- bugsink (PyPI): affected from 2.1.0; fixed in 2.1.1
- bugsink (PyPI): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40162/ (Markdown: https://insights.sbomify.com/CVE-2026-40162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40162
- OSV: https://osv.dev/vulnerability/CVE-2026-40162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40162/
Summaries are generated and may contain mistakes; the official description above is the record.
