# CVE-2026-40166: authentik: Non-admin user can retrieve confidential OAuth client_secret via /api/v3/oauth2/access_tokens/

> Authenticated non-admin users can retrieve confidential OAuth client secrets via the access tokens API, exposing sensitive credentials.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 26 May 2026
- **Also known as:** BIT-authentik-2026-40166, GHSA-hhpc-rqgm-pxj4

## What is CVE-2026-40166?

CVE-2026-40166 is a high-severity vulnerability in goauthentik authentik, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

authentik is an open-source identity provider. In versions prior to 2025.12.5 and 2026.2.0-rc1 through 2026.2.2, authenticated non-admin users with at least one OAuth2 access token can retrieve the client_secret of confidential OAuth2 providers they have previously authenticated against, exposing sensitive information to users without the correct permissions. This logic is GET /api/v3/oauth2/access_tokens/. The API response includes a nested provider object containing client_id and client_secret for providers configured with client_type: confidential, which should not be accessible to low-privilege users. This issue has been fixed in versions 2025.12.5 and 2026.2.3.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-40166?

1 open source package ship an affected version, including authentik.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2025.12.5, 2026.2.3 |

## How do I fix CVE-2026-40166?

Upgrade authentik to a fixed version for your release line: 2025.12.5 or 2026.2.3.

## Is CVE-2026-40166 being exploited?

There is no known exploitation of CVE-2026-40166 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40166 and fix it if it is affected.

What it is: CVE-2026-40166 is a high-severity vulnerability in goauthentik authentik, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40166 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2025.12.5, 2026.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40166/ (Markdown: https://insights.sbomify.com/CVE-2026-40166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40166
- OSV: https://osv.dev/vulnerability/CVE-2026-40166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40166/
Summaries are generated and may contain mistakes; the official description above is the record.
