{"answers":{"affected":"1 open source package ship an affected version, including authentik.","exploited":"There is no known exploitation of CVE-2026-40172 in the wild and no public exploit code.","fix":"Upgrade authentik to a fixed version for your release line: 2025.12.5 or 2026.2.3.","what":"CVE-2026-40172 is a high-severity vulnerability in goauthentik authentik, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40172 and fix it if it is affected.\n\nWhat it is: CVE-2026-40172 is a high-severity vulnerability in goauthentik authentik, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40172 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- authentik (Bitnami): affected all versions; fixed in 2025.12.5, 2026.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40172/ (Markdown: https://insights.sbomify.com/CVE-2026-40172/index.md)","id":"CVE-2026-40172","markdown":"https://insights.sbomify.com/CVE-2026-40172/index.md","name":"CVE-2026-40172","record":{"aliases":["BIT-authentik-2026-40172","GHSA-h6x7-hjjc-wjc9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Identity provider","requires_auth":"low_privilege","summary":"Attackers with user update permissions can escalate privileges to superuser by assigning superuser groups via the user PATCH API, bypassing intended restrictions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"authentik is an open-source identity provider. In versions prior to 2025.12.5 and 2026.2.0-rc1 through 2026.2.2, the PATCH /api/v3/core/users/{pk}/ API allows a caller with change_user on a target user to assign arbitrary groups through UserSerializer, including groups with is_superuser=True, without requiring enable_group_superuser, leading to privilege escalation. This bypasses the stricter permission model enforced in group-management paths and enables delegated user-management permissions to escalate target users to administrator-equivalent privilege. Users with permissions to update groups or permissions to update users are able to add themselves or other users they have permissions on to users which have superuser permissions. This issue has been fixed in versions 22025.12.5 and 2026.2.3.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"authentik: Privilege Escalation via User PATCH: Superuser Group Assignment Bypasses enable_group_superuser","id":"CVE-2026-40172","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"Dgraph: Unauthenticated pprof endpoint leaks admin auth token","id":"CVE-2026-40173"},"packages":[{"ecosystem":"Bitnami","fixed":["2025.12.5","2026.2.3"],"introduced":["0","2026.2.0"],"last_affected":[],"package":"authentik","purl":"pkg:bitnami/authentik","source":"BIT-authentik-2026-40172"}],"prev":{"headline":"Jupyter Notebook and JupyterLab token theft via stored XSS in help command linker","id":"CVE-2026-40171"},"products":["authentik"],"published":"2026-05-22","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-22","vendors":["goauthentik"]},"summary":"Attackers with user update permissions can escalate privileges to superuser by assigning superuser groups via the user PATCH API, bypassing intended restrictions.","url":"https://insights.sbomify.com/CVE-2026-40172/"}