CVE-2026-40176 Composer is vulnerable to Command Injection via Malicious Perforce Repository
Attackers can execute arbitrary commands via malicious Perforce parameters in composer.json, affecting developers running Composer on untrusted projects.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-40176?
CVE-2026-40176 is a high-severity command injection vulnerability in composer, published on 15 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).
Which versions are affected by CVE-2026-40176?
5 open source packages ship an affected version, including composer/composer and composer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
composer/composer Packagist | From 1.0.0 | 2.2.27 |
composer/composer Packagist | From 1.0.0 | 2.2.27 |
composer/composer Packagist | From 2.3.0 | 2.9.6 |
composer/composer Packagist | From 2.3.0 | 2.9.6 |
composer Bitnami | From 1.0.0 | 2.2.27, 2.9.6 |
Products include Getcomposer Composer.
How do I fix CVE-2026-40176?
Upgrade composer/composer to a fixed version for your release line: 2.2.27 or 2.9.6.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-40176 being exploited?
There is no known exploitation of CVE-2026-40176 in the wild and no public exploit code.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in composer
- CVE-2026-40261 Composer has Command Injection via Malicious Perforce Reference
- CVE-2024-24821 Code execution and possible privilege escalation via compromised InstalledVersions.php or installed.php in Composer
- CVE-2015-8371 Composer allows cache poisoning from other projects built on the same host
- CVE-2021-41116 Command injection in composer on Windows
- CVE-2025-67746 Composer vulnerable to ANSI sequence injection
Sources
Also known as BIT-composer-2026-40176, DEBIAN-CVE-2026-40176, GHSA-wg36-wvj6-r67p, MINI-468x-f99p-m88f, MINI-7g3q-p72q-4m55, UBUNTU-CVE-2026-40176.