# CVE-2026-40177: Password bypass when 2FA is activated

> Attackers can bypass password authentication when two-factor authentication is enabled, allowing unauthorized access to the Ajenti web panel.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-3mcx-6wxm-qr8v, PYSEC-2026-266

## What is CVE-2026-40177?

CVE-2026-40177 is a critical authentication bypass vulnerability in ajenti, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ajenti.plugin.core defines all necessary core elements to allow Ajenti to run properly. Prior to 0.112, if the 2FA was activated, it was possible to bypass the password authentication This vulnerability is fixed in 0.112.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-40177?

3 open source packages ship an affected version, including ajenti-plugin-core and ajenti.plugin.core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ajenti-plugin-core` | PyPI | All versions | 0.112 |
| `ajenti-plugin-core` | PyPI | All versions | 0.112 |
| `ajenti.plugin.core` | PyPI | All versions | 0.112 |

Products: Ajenti Ajenti Plugin Core.

## How do I fix CVE-2026-40177?

Upgrade ajenti-plugin-core to 0.112 or later.

## Is CVE-2026-40177 being exploited?

There is no known exploitation of CVE-2026-40177 in the wild and no public exploit code.

## Other vulnerabilities in ajenti

- [CVE-2026-40178](https://insights.sbomify.com/CVE-2026-40178/): ajenti.plugin.core has a race conditions in 2FA (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40177 and fix it if it is affected.

What it is: CVE-2026-40177 is a critical authentication bypass vulnerability in ajenti, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40177 in the wild and no public exploit code.

Affected packages and fixed versions:
- ajenti-plugin-core (PyPI): affected all versions; fixed in 0.112
- ajenti-plugin-core (PyPI): affected all versions; fixed in 0.112
- ajenti.plugin.core (PyPI): affected all versions; fixed in 0.112

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40177/ (Markdown: https://insights.sbomify.com/CVE-2026-40177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40177
- OSV: https://osv.dev/vulnerability/CVE-2026-40177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40177/
Summaries are generated and may contain mistakes; the official description above is the record.
