# CVE-2026-40178: ajenti.plugin.core has a race conditions in 2FA

> Attackers can bypass two-factor authentication during a brief window after login if 2FA is enabled, allowing unauthorized access to the Ajenti web panel.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-8647-755q-fw9p, PYSEC-2026-2340

## What is CVE-2026-40178?

CVE-2026-40178 is a medium-severity vulnerability in ajenti, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ajenti.plugin.core defines all necessary core elements to allow Ajenti to run properly. Prior to 0.112, if the 2FA was activated, it was possible during a short moment after the authentication of an user to bypass its authentication. This vulnerability is fixed in 0.112.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-40178?

3 open source packages ship an affected version, including ajenti-plugin-core and ajenti.plugin.core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ajenti-plugin-core` | PyPI | All versions | 0.112 |
| `ajenti-plugin-core` | PyPI | All versions | 0.112 |
| `ajenti.plugin.core` | PyPI | All versions | 0.112 |

Products: Ajenti Ajenti Plugin Core.

## How do I fix CVE-2026-40178?

Upgrade ajenti-plugin-core to 0.112 or later.

## Is CVE-2026-40178 being exploited?

There is no known exploitation of CVE-2026-40178 in the wild and no public exploit code.

## Other vulnerabilities in ajenti

- [CVE-2026-40177](https://insights.sbomify.com/CVE-2026-40177/): Password bypass when 2FA is activated (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40178 and fix it if it is affected.

What it is: CVE-2026-40178 is a medium-severity vulnerability in ajenti, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40178 in the wild and no public exploit code.

Affected packages and fixed versions:
- ajenti-plugin-core (PyPI): affected all versions; fixed in 0.112
- ajenti-plugin-core (PyPI): affected all versions; fixed in 0.112
- ajenti.plugin.core (PyPI): affected all versions; fixed in 0.112

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40178/ (Markdown: https://insights.sbomify.com/CVE-2026-40178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40178
- OSV: https://osv.dev/vulnerability/CVE-2026-40178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40178/
Summaries are generated and may contain mistakes; the official description above is the record.
