# CVE-2026-40182: OpenTelemetry dotnet: OTLP exporter reads unbounded HTTP response bodies

> An attacker can cause memory exhaustion in applications using OpenTelemetry dotnet by returning large error responses from a compromised or MitM'd telemetry backend.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-q834-8qmm-v933, MINI-69f7-p9h3-5xwr

## What is CVE-2026-40182?

CVE-2026-40182 is a medium-severity denial of service vulnerability in open-telemetry opentelemetry-dotnet, published on 23 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenTelemetry dotnet is a dotnet telemetry framework. From 1.13.1 to before 1.15.2, When exporting telemetry to a back-end/collector over gRPC or HTTP using OpenTelemetry Protocol format (OTLP), if the request results in a unsuccessful request (i.e. HTTP 4xx or 5xx), the response is read into memory with no upper-bound on the number of bytes consumed. This could cause memory exhaustion in the consuming application if the configured back-end/collector endpoint is attacker-controlled (or a network attacker can MitM the connection) and an extremely large body is returned by the response. This vulnerability is fixed in 1.15.2.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-40182?

2 open source packages ship an affected version, including OpenTelemetry.Exporter.OpenTelemetryProtocol. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OpenTelemetry.Exporter.OpenTelemetryProtocol` | NuGet | From 1.13.1 | 1.15.2 |
| `OpenTelemetry.Exporter.OpenTelemetryProtocol` | NuGet | From 1.13.1 | 1.15.2 |

Products: Opentelemetry Opentelemetry.

## How do I fix CVE-2026-40182?

Upgrade OpenTelemetry.Exporter.OpenTelemetryProtocol to 1.15.2 or later.

## Is CVE-2026-40182 being exploited?

There is no known exploitation of CVE-2026-40182 in the wild and no public exploit code.

## Other vulnerabilities in open-telemetry opentelemetry-dotnet

- [CVE-2026-29181](https://insights.sbomify.com/CVE-2026-29181/): OpenTelemetry-Go multi-value `baggage` header extraction causes excessive allocations (remote dos amplification) (high 7.5)
- [CVE-2023-47108](https://insights.sbomify.com/CVE-2023-47108/): DoS vulnerability in otelgrpc (uncontrolled resource consumption) due to unbound cardinality metrics (high 7.5)
- [CVE-2023-45142](https://insights.sbomify.com/CVE-2023-45142/): OpenTelemetry-Go Contrib has DoS vulnerability in otelhttp due to unbound cardinality metrics (high 7.5)
- [CVE-2023-43810](https://insights.sbomify.com/CVE-2023-43810/): opentelemetry-instrumentation Denial of Service vulnerability due to unbound cardinality metrics (high 7.5)
- [CVE-2026-39883](https://insights.sbomify.com/CVE-2026-39883/): opentelemetry-go: BSD kenv command not using absolute path enables PATH hijacking (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40182 and fix it if it is affected.

What it is: CVE-2026-40182 is a medium-severity denial of service vulnerability in open-telemetry opentelemetry-dotnet, published on 23 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40182 in the wild and no public exploit code.

Affected packages and fixed versions:
- OpenTelemetry.Exporter.OpenTelemetryProtocol (NuGet): affected from 1.13.1; fixed in 1.15.2
- OpenTelemetry.Exporter.OpenTelemetryProtocol (NuGet): affected from 1.13.1; fixed in 1.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40182/ (Markdown: https://insights.sbomify.com/CVE-2026-40182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40182
- OSV: https://osv.dev/vulnerability/CVE-2026-40182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40182/
Summaries are generated and may contain mistakes; the official description above is the record.
