CVE-2026-40186 ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements
Attackers can inject arbitrary HTML and scripts via entity-encoded text in textarea or option elements, bypassing sanitization filters in ApostropheCMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-40186?
CVE-2026-40186 is a medium-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
ApostropheCMS is an open-source Node.js content management system. A regression introduced in commit 49d0bb7, included in versions 2.17.1 of the ApostropheCMS-maintained sanitize-html package bypasses allowedTags enforcement for text inside nonTextTagsArray elements (textarea and option). ApostropheCMS version 4.28.0 is affected through its dependency on the vulnerable sanitize-html version. The code at packages/sanitize-html/index.js:569-573 incorrectly assumes that htmlparser2 does not decode entities inside these elements and skips escaping, but htmlparser2 10.x does decode entities before passing text to the ontext callback. As a result, entity-encoded HTML is decoded by the parser and then written directly to the output as literal HTML characters, completely bypassing the allowedTags filter. An attacker can inject arbitrary tags including XSS payloads through any allowed option or textarea element using entity encoding. This affects non-default configurations where option or textarea are included in allowedTags, which is common in form builders and CMS platforms. This issue has been fixed in version 2.17.2 of sanitize-html and 4.29.0 of ApostropheCMS.
Weakness: CWE-79
Which versions are affected by CVE-2026-40186?
2 open source packages ship an affected version, including sanitize-html. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
sanitize-html npm | From 2.17.2 | 2.17.3 |
sanitize-html npm | From 2.17.2 | 2.17.3 |
Products include Apostrophecms Apostrophecms, Apostrophecms Sanitize-Html.
How do I fix CVE-2026-40186?
Upgrade sanitize-html to 2.17.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-40186 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40186 exists.
Other vulnerabilities in apostrophecms apostrophe
- CVE-2021-25979 Apostrophe - Insufficient Session Expiration
- CVE-2026-35569 ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS
- CVE-2026-32730 ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware
- CVE-2026-33889 ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context
- CVE-2021-25978 Apostrophe - XSS
Sources
Also known as GHSA-9mrh-v2v3-xpfm.