{"answers":{"affected":"2 open source packages ship an affected version, including sanitize-html. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40186 exists.","fix":"Upgrade sanitize-html to 2.17.3 or later.","what":"CVE-2026-40186 is a medium-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-40186 and fix it if it is affected.\n\nWhat it is: CVE-2026-40186 is a medium-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40186 exists.\n\nAffected packages and fixed versions:\n- sanitize-html (npm): affected from 2.17.2; fixed in 2.17.3\n- sanitize-html (npm): affected from 2.17.2; fixed in 2.17.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40186/ (Markdown: https://insights.sbomify.com/CVE-2026-40186/index.md)","id":"CVE-2026-40186","markdown":"https://insights.sbomify.com/CVE-2026-40186/index.md","name":"CVE-2026-40186","record":{"aliases":["GHSA-9mrh-v2v3-xpfm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"ApostropheCMS","requires_auth":"none","summary":"Attackers can inject arbitrary HTML and scripts via entity-encoded text in textarea or option elements, bypassing sanitization filters in ApostropheCMS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apostrophecms","vendor":"apostrophecms"},{"product":"sanitize-html","vendor":"apostrophecms"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ApostropheCMS is an open-source Node.js content management system. A regression introduced in commit 49d0bb7, included in versions 2.17.1 of the ApostropheCMS-maintained sanitize-html package bypasses allowedTags enforcement for text inside nonTextTagsArray elements (textarea and option). ApostropheCMS version 4.28.0 is affected through its dependency on the vulnerable sanitize-html version. The code at packages/sanitize-html/index.js:569-573 incorrectly assumes that htmlparser2 does not decode entities inside these elements and skips escaping, but htmlparser2 10.x does decode entities before passing text to the ontext callback. As a result, entity-encoded HTML is decoded by the parser and then written directly to the output as literal HTML characters, completely bypassing the allowedTags filter. An attacker can inject arbitrary tags including XSS payloads through any allowed option or textarea element using entity encoding. This affects non-default configurations where option or textarea are included in allowedTags, which is common in form builders and CMS platforms. This issue has been fixed in version 2.17.2 of sanitize-html and 4.29.0 of ApostropheCMS.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements","id":"CVE-2026-40186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Authenticated RCE via Malicious eTemplate Upload in EGroupware","id":"CVE-2026-40187"},"packages":[{"ecosystem":"npm","fixed":["2.17.3"],"introduced":["2.17.2"],"last_affected":[],"package":"sanitize-html","purl":null,"source":"GHSA-9mrh-v2v3-xpfm"},{"ecosystem":"npm","fixed":["2.17.3"],"introduced":["2.17.2"],"last_affected":[],"package":"sanitize-html","purl":"pkg:npm/sanitize-html","source":"GHSA-9mrh-v2v3-xpfm"}],"prev":{"headline":"Missing Authorization on Immich Trip Photo Routes in TREK","id":"CVE-2026-40185"},"products":["apostrophe","sanitize-html"],"published":"2026-04-15","related":[{"cvss_score":9.8,"headline":"Apostrophe - Insufficient Session Expiration","id":"CVE-2021-25979","kev_date_added":null,"published":"2021-11-08"},{"cvss_score":8.7,"headline":"ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS","id":"CVE-2026-35569","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":8.1,"headline":"ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware","id":"CVE-2026-32730","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":5.4,"headline":"ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context","id":"CVE-2026-33889","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"Apostrophe - XSS","id":"CVE-2021-25978","kev_date_added":null,"published":"2021-11-07"},{"cvss_score":5.3,"headline":"ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API","id":"CVE-2026-33888","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["apostrophecms"]},"summary":"Attackers can inject arbitrary HTML and scripts via entity-encoded text in textarea or option elements, bypassing sanitization filters in ApostropheCMS.","url":"https://insights.sbomify.com/CVE-2026-40186/"}