# CVE-2026-40189: goshs has a file-based ACL authorization bypass in goshs state-changing routes

> Unauthenticated attackers can bypass ACLs to upload, delete, or modify files in protected directories, potentially removing the ACL file to gain full access.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-wvhv-qcqf-f3cx, GO-2026-5728

## What is CVE-2026-40189?

CVE-2026-40189 is a critical missing authorization vulnerability in patrickhener goshs, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

goshs is a SimpleHTTPServer written in Go. Prior to 2.0.0-beta.4, goshs enforces the documented per-folder .goshs ACL/basic-auth mechanism for directory listings and file reads, but it does not enforce the same authorization checks for state-changing routes. An unauthenticated attacker can upload files with PUT, upload files with multipart POST /upload, create directories with ?mkdir, and delete files with ?delete inside a .goshs-protected directory. By deleting the .goshs file itself, the attacker can remove the folder's auth policy and then access previously protected content without credentials. This results in a critical authorization bypass affecting confidentiality, integrity, and availability. This vulnerability is fixed in 2.0.0-beta.4.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-40189?

3 open source packages ship an affected version, including github.com/patrickhener/goshs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/patrickhener/goshs` | Go | All versions | None |
| `github.com/patrickhener/goshs` | Go | All versions to 1.1.4 | None |
| `github.com/patrickhener/goshs` | Go | All versions to 1.1.4 | None |

Products: Goshs Goshs.

## How do I fix CVE-2026-40189?

Upgrade to a fixed version.

## Is CVE-2026-40189 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40189 exists.

## Other vulnerabilities in patrickhener goshs

- [CVE-2026-40884](https://insights.sbomify.com/CVE-2026-40884/): goshs: Empty-username SFTP password authentication bypass in goshs (critical 9.8)
- [CVE-2026-35392](https://insights.sbomify.com/CVE-2026-35392/): goshs has an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in goshs PUT Upload (critical 9.8)
- [CVE-2026-35393](https://insights.sbomify.com/CVE-2026-35393/): Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in goshs POST multipart upload (critical 9.8)
- [CVE-2026-35471](https://insights.sbomify.com/CVE-2026-35471/): Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in goshs (critical 9.8)
- [CVE-2026-40903](https://insights.sbomify.com/CVE-2026-40903/): Goshs - ArtiPACKED Vulnerability – GitHub Actions Credential Persistence (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40189 and fix it if it is affected.

What it is: CVE-2026-40189 is a critical missing authorization vulnerability in patrickhener goshs, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40189 exists.

Affected packages and fixed versions:
- github.com/patrickhener/goshs (Go): affected all versions; no fix listed
- github.com/patrickhener/goshs (Go): affected all versions up to 1.1.4; no fix listed
- github.com/patrickhener/goshs (Go): affected all versions up to 1.1.4; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40189/ (Markdown: https://insights.sbomify.com/CVE-2026-40189/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40189
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40189
- OSV: https://osv.dev/vulnerability/CVE-2026-40189

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40189/
Summaries are generated and may contain mistakes; the official description above is the record.
