# CVE-2026-40192: Pillow is vulnerable to a FITS GZIP decompression bomb

> Attackers can cause denial of service via memory exhaustion by submitting crafted FITS images to applications using the Pillow library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 10 Sep 2026
- **Also known as:** BIT-pillow-2026-40192, CLEANSTART-2026-OR44215, CLEANSTART-2026-XY80928, CLSA-2026-1776904626, CLSA-2026-1778028238, CLSA-2026-1781744117, DEBIAN-CVE-2026-40192, ECHO-1c52-724c-58ad, GHSA-whj4-6x5x-4v2j, MINI-2chm-2x2q-gc63, MINI-6gqq-hv5v-2xxg, MINI-7f9h-hc64-3gp2, MINI-cgvm-rf57-qghv, MINI-qhfq-fq5m-w9rg, MINI-w3r7-2c85-94hc, MINI-wj2w-5fhw-9vf3, OESA-2026-2064, OESA-2026-2065, OESA-2026-2066, PYSEC-2026-2250, ROOT-APP-PYPI-CVE-2026-40192, SUSE-SU-2026:21382-1, UBUNTU-CVE-2026-40192, openSUSE-SU-2026:10575-1, openSUSE-SU-2026:20617-1

## What is CVE-2026-40192?

CVE-2026-40192 is a high-severity denial of service vulnerability in Python Pillow, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. Versions 10.3.0 through 12.1.1 did not limit the amount of GZIP-compressed data read when decoding a FITS image, making them vulnerable to decompression bomb attacks. A specially crafted FITS file could cause unbounded memory consumption, leading to denial of service (OOM crash or severe performance degradation). If users are unable to immediately upgrade, they should only open specific image formats, excluding FITS, as a workaround.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-40192?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 10.3.0 | 12.2.0 |
| `pillow` | PyPI | From 10.3.0 | 12.2.0 |
| `pillow` | PyPI | From 10.3.0 | 12.2.0 |
| `pillow` | PyPI | From 10.3.0 | 12.2.0 |
| `python-Pillow` | openSUSE:Leap 16.0 | All versions | 11.3.0-160000.4.1 |
| `python-Pillow` | openSUSE:Tumbleweed | All versions | 12.2.0-2.1 |

Products: Python Pillow.

## How do I fix CVE-2026-40192?

Upgrade pillow to 12.2.0 or later.

## Is CVE-2026-40192 being exploited?

There is no known exploitation of CVE-2026-40192 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40192 and fix it if it is affected.

What it is: CVE-2026-40192 is a high-severity denial of service vulnerability in Python Pillow, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40192 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 10.3.0; fixed in 12.2.0
- pillow (PyPI): affected from 10.3.0; fixed in 12.2.0
- pillow (PyPI): affected from 10.3.0; fixed in 12.2.0
- pillow (PyPI): affected from 10.3.0; fixed in 12.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40192/ (Markdown: https://insights.sbomify.com/CVE-2026-40192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40192
- OSV: https://osv.dev/vulnerability/CVE-2026-40192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40192/
Summaries are generated and may contain mistakes; the official description above is the record.
