# CVE-2026-40195: Incus nil-pointer dereference in storage bucket import allows denial of service

> An authenticated user can crash the Incus daemon by importing a storage bucket with a malformed index.yaml file, causing a denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-40195, GHSA-gc7j-g665-rxr9, GO-2026-5397, UBUNTU-CVE-2026-40195

## What is CVE-2026-40195?

CVE-2026-40195 is a high-severity vulnerability in lxc incus, published on 6 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. In versions before 7.0.0, missing validation logic in the storage bucket import logic allows an authenticated user with access to the storage bucket feature to cause the Incus daemon to crash. The vulnerability is present in the backup metadata handling logic, where the daemon processes the index.yaml file from an imported archive and accesses members of the parsed backup configuration without first verifying that the configuration object was initialized. A malicious or malformed index.yaml that omits the config block causes a nil-pointer dereference during bucket import operations and terminates the daemon. Repeated use of this issue can be used to keep Incus offline, causing a denial of service. This issue is fixed in version 7.0.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-40195?

5 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |
| `github.com/lxc/incus/v7` | Go | All versions | 7.0.0 |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-40195?

Upgrade github.com/lxc/incus/v6/cmd/incusd to 7.0.0 or later.

## Is CVE-2026-40195 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40195 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40195 and fix it if it is affected.

What it is: CVE-2026-40195 is a high-severity vulnerability in lxc incus, published on 6 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40195 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed
- github.com/lxc/incus/v7 (Go): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40195/ (Markdown: https://insights.sbomify.com/CVE-2026-40195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40195
- OSV: https://osv.dev/vulnerability/CVE-2026-40195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40195/
Summaries are generated and may contain mistakes; the official description above is the record.
