# CVE-2026-40197: Incus nil-pointer dereference in custom volume import allows denial of service

> An authenticated user can crash the Incus daemon by importing a malicious backup archive with null snapshot entries, causing denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-40197, GHSA-r7w7-mmxr-47r9, GO-2026-5612, UBUNTU-CVE-2026-40197

## What is CVE-2026-40197?

CVE-2026-40197 is a high-severity vulnerability in lxc incus, published on 6 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. In versions before 7.0.0, missing validation logic in the storage volume import logic allows an authenticated user with access to the storage volume feature to cause the Incus daemon to crash. The custom volume backup import subsystem contains a nil-pointer dereference vulnerability during import operations. In the snapshot import loop, the daemon iterates over entries from `srcBackup.Config.VolumeSnapshots` and assumes that each slice element is initialized, then dereferences fields such as `Name`, `Config`, `Description`, `CreatedAt`, and `ExpiresAt` without first validating the element itself. Because the yaml unmarshaler accepts explicit null array elements from an attacker-controlled index.yaml and converts them into nil pointers inside the slice, an attacker can supply a backup archive containing a null entry in the volume_snapshots array. This causes a nil-pointer dereference during custom volume import and terminates the daemon, resulting in denial of service on the affected node. Repeated use of this issue can be used to keep Incus offline, causing a denial of service. This issue is fixed in version 7.0.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-40197?

5 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |
| `github.com/lxc/incus/v7` | Go | All versions | 7.0.0 |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-40197?

Upgrade github.com/lxc/incus/v6/cmd/incusd to 7.0.0 or later.

## Is CVE-2026-40197 being exploited?

There is no known exploitation of CVE-2026-40197 in the wild and no public exploit code.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40197 and fix it if it is affected.

What it is: CVE-2026-40197 is a high-severity vulnerability in lxc incus, published on 6 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40197 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed
- github.com/lxc/incus/v7 (Go): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40197/ (Markdown: https://insights.sbomify.com/CVE-2026-40197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40197
- OSV: https://osv.dev/vulnerability/CVE-2026-40197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40197/
Summaries are generated and may contain mistakes; the official description above is the record.
