# CVE-2026-40213: OpenStack Cyborg uses rule:allow (check_str='@') as the default policy for multiple API endpoints

> An authenticated user with no roles can bypass authorization checks to reprogram FPGA bitstreams on arbitrary compute nodes in OpenStack Cyborg.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** DEBIAN-CVE-2026-40213, GHSA-mm7j-mhhj-hj36, PYSEC-2026-2853, UBUNTU-CVE-2026-40213

## What is CVE-2026-40213?

CVE-2026-40213 is a high-severity missing authorization vulnerability in OpenStack Cyborg, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Cyborg before 16.0.1 uses rule:allow (check_str='@') as the default policy for multiple API endpoints. This unconditionally authorizes any request carrying a valid Keystone token regardless of roles, project membership, or scope. An authenticated user with zero role assignments can complete various actions such as reprogramming FPGA bitstreams on arbitrary compute nodes via agent RPC.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-40213?

3 open source packages ship an affected version, including openstack-cyborg.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openstack-cyborg` | PyPI | All versions | 16.0.1 |
| `openstack-cyborg` | PyPI | All versions | 16.0.1 |
| `openstack-cyborg` | PyPI | All versions | 16.0.1 |

## How do I fix CVE-2026-40213?

Upgrade openstack-cyborg to 16.0.1 or later.

## Is CVE-2026-40213 being exploited?

There is no known exploitation of CVE-2026-40213 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40213 and fix it if it is affected.

What it is: CVE-2026-40213 is a high-severity missing authorization vulnerability in OpenStack Cyborg, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40213 in the wild and no public exploit code.

Affected packages and fixed versions:
- openstack-cyborg (PyPI): affected all versions; fixed in 16.0.1
- openstack-cyborg (PyPI): affected all versions; fixed in 16.0.1
- openstack-cyborg (PyPI): affected all versions; fixed in 16.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40213/ (Markdown: https://insights.sbomify.com/CVE-2026-40213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40213
- OSV: https://osv.dev/vulnerability/CVE-2026-40213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40213/
Summaries are generated and may contain mistakes; the official description above is the record.
