# CVE-2026-40217: LiteLLM has a sandbox escape in custom-code guardrail

> Remote attackers can execute arbitrary code via bytecode rewriting in the LiteLLM library, requiring immediate upgrades.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-IM10707, CLEANSTART-2026-UL91233, ECHO-c6d4-cf5f-a050, GHSA-wxxx-gvqv-xp7p, MINI-377r-r3c8-mhq7, MINI-3vcp-7r7v-gxq6, MINI-5mf2-rwc5-qrh5, MINI-6x4w-cc8c-6xw4, MINI-c8gj-mj24-qpfx, MINI-f7r9-xw6c-prv2, MINI-gcpx-2fm7-c67c, MINI-h97j-rjvr-jv7v, MINI-j48c-h23c-j59g, MINI-pgfq-mvrg-8hc5, MINI-prjc-4w9x-fr27, MINI-r977-hmxh-w444, MINI-v6qx-f2q3-8qqf, MINI-wwwm-p4q4-r55j, PYSEC-2026-2601

## What is CVE-2026-40217?

CVE-2026-40217 is a high-severity code injection vulnerability in BerriAI LiteLLM, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM through 2026-04-08 allows remote attackers to execute arbitrary code via bytecode rewriting at the /guardrails/test_custom_code URI.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-420 (Unprotected Alternate Channel)

## Which versions are affected by CVE-2026-40217?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | From 1.81.8 | 1.83.10 |
| `litellm` | PyPI | From 1.81.8 | 1.83.10 |
| `litellm` | PyPI | From 1.81.8 | 1.83.10 |

Products: Litellm Litellm.

## How do I fix CVE-2026-40217?

Upgrade litellm to 1.83.10 or later.

## Is CVE-2026-40217 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40217 exists.

Public exploit code:

- The code for personally reproducing the corresponding vulnerability (github_poc): https://github.com/learner202649/CVE-2026-40217-PoC
- LiteLLM < 1.25.0 - Remote Code Execution (nuclei): http/cves/2026/CVE-2026-40217.yaml

## Other vulnerabilities in BerriAI LiteLLM

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40217 and fix it if it is affected.

What it is: CVE-2026-40217 is a high-severity code injection vulnerability in BerriAI LiteLLM, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40217 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected from 1.81.8; fixed in 1.83.10
- litellm (PyPI): affected from 1.81.8; fixed in 1.83.10
- litellm (PyPI): affected from 1.81.8; fixed in 1.83.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40217/ (Markdown: https://insights.sbomify.com/CVE-2026-40217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40217
- OSV: https://osv.dev/vulnerability/CVE-2026-40217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40217/
Summaries are generated and may contain mistakes; the official description above is the record.
