# CVE-2026-40243: Incus OVN TLS verification accepts peer-supplied roots and permits endpoint impersonation

> Attackers can impersonate OVN database endpoints by bypassing TLS verification, allowing interception of management traffic in OVN-enabled deployments.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:A/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-40243, GHSA-c839-4qxr-j4x3, GO-2026-5319, UBUNTU-CVE-2026-40243

## What is CVE-2026-40243?

CVE-2026-40243 is a low-severity vulnerability in lxc incus, published on 6 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. In versions before 7.0.0, broken TLS validation logic in the OVN database connection logic can allow connections to an attacker's OVN database. The OVN client implementations disable Go standard TLS server verification and replace it with custom peer-certificate verification logic. That replacement verifier does not anchor trust in the configured CA certificate. Instead, it constructs the verification root set from certificates supplied by the peer during the handshake, so the configured CA is parsed but not used as the trust anchor for the final verification decision.

In OVN-enabled deployments that use these SSL database connection paths, an attacker able to impersonate or intercept the OVN endpoint on the management network can present a rogue self-signed certificate chain, and Incus will accept this certificate as valid. This issue defeats the intended CA-based trust model for OVN database connections and permits endpoint impersonation by an active attacker in a suitable network position. This issue is fixed in version 7.0.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-40243?

5 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus/v6/cmd/incusd` | Go | All versions | 7.0.0 |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |
| `github.com/lxc/incus/v7` | Go | All versions | 7.0.0 |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-40243?

Upgrade github.com/lxc/incus/v6/cmd/incusd to 7.0.0 or later.

## Is CVE-2026-40243 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40243 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40243 and fix it if it is affected.

What it is: CVE-2026-40243 is a low-severity vulnerability in lxc incus, published on 6 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40243 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus/v6/cmd/incusd (Go): affected all versions; fixed in 7.0.0
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed
- github.com/lxc/incus/v7 (Go): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40243/ (Markdown: https://insights.sbomify.com/CVE-2026-40243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40243
- OSV: https://osv.dev/vulnerability/CVE-2026-40243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40243/
Summaries are generated and may contain mistakes; the official description above is the record.
