# CVE-2026-40260: pypdf: Manipulated XMP metadata entity declarations can exhaust RAM

> Attackers can cause memory exhaustion and denial of service by crafting PDFs with manipulated XMP metadata, affecting users of the pypdf library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2026
- **Updated:** 17 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-40260, ECHO-a89e-cd54-99ff, GHSA-3crg-w4f6-42mx, MINI-rfx2-7jr3-pxc3, MINI-vx82-mp34-7qmq, PYSEC-2026-3006, ROOT-APP-PYPI-CVE-2026-40260, UBUNTU-CVE-2026-40260, openSUSE-SU-2026:10582-1, openSUSE-SU-2026:10583-1

## What is CVE-2026-40260?

CVE-2026-40260 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pypdf is a free and open-source pure-python PDF library. In versions prior to 6.10.0, manipulated XMP metadata entity declarations can exhaust RAM. An attacker who exploits this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the XMP metadata. This issue has been fixed in version 6.10.0.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2026-40260?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.10.0 |
| `pypdf` | PyPI | All versions | 6.10.0 |
| `pypdf` | PyPI | All versions | 6.10.0 |
| `python-PyPDF2` | openSUSE:Tumbleweed | All versions | 2.11.1-9.1 |
| `python-pypdf` | openSUSE:Tumbleweed | All versions | 6.10.2-1.1 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-40260?

Upgrade pypdf to 6.10.0 or later.

## Is CVE-2026-40260 being exploited?

There is no known exploitation of CVE-2026-40260 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40260 and fix it if it is affected.

What it is: CVE-2026-40260 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40260 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.10.0
- pypdf (PyPI): affected all versions; fixed in 6.10.0
- pypdf (PyPI): affected all versions; fixed in 6.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40260/ (Markdown: https://insights.sbomify.com/CVE-2026-40260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40260
- OSV: https://osv.dev/vulnerability/CVE-2026-40260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40260/
Summaries are generated and may contain mistakes; the official description above is the record.
