# CVE-2026-40261: Composer has Command Injection via Malicious Perforce Reference

> Attackers can execute arbitrary commands via malicious package metadata in Composer, affecting developers installing dependencies from source.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-composer-2026-40261, DEBIAN-CVE-2026-40261, GHSA-gqw4-4w2p-838q, MINI-2jj7-qpww-7f59, MINI-h2qp-83g4-h3f7, UBUNTU-CVE-2026-40261

## What is CVE-2026-40261?

CVE-2026-40261 is a high-severity command injection vulnerability in composer, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::syncCodeBase() method, which appends the $sourceReference parameter to a shell command without proper escaping, and additionally in the Perforce::generateP4Command() method as in GHSA-wg36-wvj6-r67p / CVE-2026-40176, which interpolates user-supplied Perforce connection parameters (port, user, client) from the source url field without proper escaping. An attacker can inject arbitrary commands through crafted source reference or source url values containing shell metacharacters, even if Perforce is not installed. Unlike CVE-2026-40176, the source reference and url are provided as part of package metadata, meaning any compromised or malicious Composer repository can serve package metadata declaring perforce as a source type with malicious values. This vulnerability is exploitable when installing or updating dependencies from source, including the default behavior when installing dev-prefixed versions. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline). If developers are unable to immediately update, they can avoid installing dependencies from source by using --prefer-dist or the preferred-install: dist config setting, and only use trusted Composer repositories as a workaround.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-40261?

5 open source packages ship an affected version, including composer/composer and composer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `composer/composer` | Packagist | From 1.0.0 | 2.2.27 |
| `composer/composer` | Packagist | From 1.0.0 | 2.2.27 |
| `composer/composer` | Packagist | From 2.3.0 | 2.9.6 |
| `composer/composer` | Packagist | From 2.3.0 | 2.9.6 |
| `composer` | Bitnami | From 1.0.0 | 2.2.27, 2.9.6 |

Products: Getcomposer Composer.

## How do I fix CVE-2026-40261?

Upgrade composer/composer to a fixed version for your release line: 2.2.27 or 2.9.6.

## Is CVE-2026-40261 being exploited?

There is no known exploitation of CVE-2026-40261 in the wild and no public exploit code.

Public exploit code:

- https://github.com/terminat0r7031/composer-CVE-2026-40261-CVE-2026-40176-PoC (github_poc): https://github.com/terminat0r7031/composer-CVE-2026-40261-CVE-2026-40176-PoC

## Other vulnerabilities in composer

- [CVE-2024-24821](https://insights.sbomify.com/CVE-2024-24821/): Code execution and possible privilege escalation via compromised InstalledVersions.php or installed.php in Composer (high 8.8)
- [CVE-2015-8371](https://insights.sbomify.com/CVE-2015-8371/): Composer allows cache poisoning from other projects built on the same host (high 8.8)
- [CVE-2021-41116](https://insights.sbomify.com/CVE-2021-41116/): Command injection in composer on Windows (high 8.2)
- [CVE-2026-40176](https://insights.sbomify.com/CVE-2026-40176/): Composer is vulnerable to Command Injection via Malicious Perforce Repository (high 7.8)
- [CVE-2025-67746](https://insights.sbomify.com/CVE-2025-67746/): Composer vulnerable to ANSI sequence injection (low 1.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40261 and fix it if it is affected.

What it is: CVE-2026-40261 is a high-severity command injection vulnerability in composer, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-40261 in the wild and no public exploit code.

Affected packages and fixed versions:
- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.27
- composer/composer (Packagist): affected from 1.0.0; fixed in 2.2.27
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.9.6
- composer/composer (Packagist): affected from 2.3.0; fixed in 2.9.6
- composer (Bitnami): affected from 1.0.0; fixed in 2.2.27, 2.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40261/ (Markdown: https://insights.sbomify.com/CVE-2026-40261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40261
- OSV: https://osv.dev/vulnerability/CVE-2026-40261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40261/
Summaries are generated and may contain mistakes; the official description above is the record.
