# CVE-2026-40280: Gotenberg SSRF via case-insensitive URL scheme bypass in webhook and downloadFrom deny-lists

> Attackers can bypass IP deny-lists via case-insensitive URL schemes to access internal services and cloud metadata in Gotenberg.

- **Severity:** High 7.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-5q7p-7jgv-ww56, GO-2026-5151

## What is CVE-2026-40280?

CVE-2026-40280 is a high-severity server-side request forgery vulnerability in gotenberg, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gotenberg is an API-based document conversion tool. In versions 8.30.1 and earlier, the default private-IP deny-lists for the --webhook-deny-list and --api-download-from-deny-list flags use a case-sensitive regular expression (^https?://) to match URL schemes. Because Go's net/url.Parse() normalizes the scheme to lowercase before establishing the outbound TCP connection, an attacker can bypass the deny-list by simply capitalizing part of the URL scheme (e.g., HTTP://, HTTPS://, or Http://). This allows unauthenticated requests to reach internal network services, including private IP ranges, loopback addresses, and cloud instance metadata endpoints such as HTTP://169.254.169.254/latest/meta-data/. 

This bypasses the same security control that was patched in CVE-2026-27018.

This issue has been fixed in version 8.31.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-40280?

4 open source packages ship an affected version, including github.com/gotenberg/gotenberg/v8 and github.com/gotenberg/gotenberg/v7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.31.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.31.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.31.0 |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions | None |

Products: Thecodingmachine Gotenberg.

## How do I fix CVE-2026-40280?

Upgrade github.com/gotenberg/gotenberg/v8 to 8.31.0 or later.

## Is CVE-2026-40280 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40280 exists.

Public exploit code:

- Gotenberg <= 8.30.1 - Server Side Request Forgery (nuclei): http/cves/2026/CVE-2026-40280.yaml

## Other vulnerabilities in gotenberg

- [CVE-2026-40281](https://insights.sbomify.com/CVE-2026-40281/): Gotenberg vulnerable to argument injection via newlines in ExifTool metadata values (critical 10.0)
- [CVE-2026-42589](https://insights.sbomify.com/CVE-2026-42589/): Gotenberg: Unauthenticated RCE via ExifTool Metadata Key Injection (critical 9.8)
- [CVE-2020-13450](https://insights.sbomify.com/CVE-2020-13450/): Path traversal in n/a (critical 9.8)
- [CVE-2020-13451](https://insights.sbomify.com/CVE-2020-13451/): Code injection in n/a (critical 9.8)
- [CVE-2020-13452](https://insights.sbomify.com/CVE-2020-13452/): Privilege escalation in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40280 and fix it if it is affected.

What it is: CVE-2026-40280 is a high-severity server-side request forgery vulnerability in gotenberg, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40280 exists.

Affected packages and fixed versions:
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.31.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.31.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.31.0
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40280/ (Markdown: https://insights.sbomify.com/CVE-2026-40280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40280
- OSV: https://osv.dev/vulnerability/CVE-2026-40280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40280/
Summaries are generated and may contain mistakes; the official description above is the record.
