# CVE-2026-40281: Gotenberg vulnerable to argument injection via newlines in ExifTool metadata values

> An unauthenticated attacker can inject arguments into ExifTool via newlines in metadata values, allowing arbitrary file manipulation or code execution within the container.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-q7r4-hc83-hf2q, GO-2026-5572

## What is CVE-2026-40281?

CVE-2026-40281 is a critical command injection vulnerability in gotenberg, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-40281?

4 open source packages ship an affected version, including github.com/gotenberg/gotenberg/v8 and github.com/gotenberg/gotenberg/v7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.31.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.31.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.31.0 |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions | None |

Products: Thecodingmachine Gotenberg.

## How do I fix CVE-2026-40281?

Upgrade github.com/gotenberg/gotenberg/v8 to 8.31.0 or later.

## Is CVE-2026-40281 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40281 exists.

Public exploit code:

- Gotenberg 8.30.1 unauthenticated RCE exploit (github_poc): https://github.com/MRdark-ops/CVE-2026-40281-exploit
- Gotenberg <= 8.30.1 unauthenticated RCE (github_poc): https://github.com/0xgh057r3c0n/CVE-2026-40281
- A Working PoC For CVE-2026-40281 (github_poc): https://github.com/rabakuku/CVE-2026-40281
- Gotenberg <= 8.30.1 - Remote Code Execution (nuclei): http/cves/2026/CVE-2026-40281.yaml

## Other vulnerabilities in gotenberg

- [CVE-2026-42589](https://insights.sbomify.com/CVE-2026-42589/): Gotenberg: Unauthenticated RCE via ExifTool Metadata Key Injection (critical 9.8)
- [CVE-2020-13450](https://insights.sbomify.com/CVE-2020-13450/): Path traversal in n/a (critical 9.8)
- [CVE-2020-13451](https://insights.sbomify.com/CVE-2020-13451/): Code injection in n/a (critical 9.8)
- [CVE-2020-13452](https://insights.sbomify.com/CVE-2020-13452/): Privilege escalation in n/a (critical 9.8)
- [CVE-2026-42596](https://insights.sbomify.com/CVE-2026-42596/): Gotenberg: Unauthenticated SSRF via default deny-list bypass in downloadFrom and webhook (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40281 and fix it if it is affected.

What it is: CVE-2026-40281 is a critical command injection vulnerability in gotenberg, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40281 exists.

Affected packages and fixed versions:
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.31.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.31.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.31.0
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40281/ (Markdown: https://insights.sbomify.com/CVE-2026-40281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40281
- OSV: https://osv.dev/vulnerability/CVE-2026-40281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40281/
Summaries are generated and may contain mistakes; the official description above is the record.
