CVE-2026-40287 PraisonAI has RCE via Automatic tools.py Import

High 8.4 Published Updated

Attackers can execute arbitrary code by placing a malicious tools.py file in the working directory, affecting PraisonAI users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40287?

CVE-2026-40287 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

PraisonAI is a multi-agent teams system. Versions 4.5.138 and below are vulnerable to arbitrary code execution through automatic, unsanitized import of a tools.py file from the current working directory. Components including call.py (import_tools_from_file()), tool_resolver.py (_load_local_tools()), and CLI tool-loading paths blindly import ./tools.py at startup without any validation, sandboxing, or user confirmation. An attacker who can place a malicious tools.py in the directory where PraisonAI is launched (such as through a shared project, cloned repository, or writable workspace) achieves immediate arbitrary Python code execution in the host environment. This compromises the full PraisonAI process, the host system, and any connected data or credentials. This issue has been fixed in version 4.5.139.

Weakness: CWE-94, CWE-426

Which versions are affected by CVE-2026-40287?

6 open source packages ship an affected version, including praisonaiagents, PraisonAI and praisonai. It affects 2 products.

PackageAffectedFixed in
praisonaiagents PyPIAll versions1.5.140
praisonaiagents PyPIAll versions1.5.140
praisonaiagents PyPIAll versions1.5.140
PraisonAI PyPIAll versions4.5.139
praisonai PyPIAll versions4.5.139
praisonai PyPIAll versions4.5.139

Products include Praison Praisonai, Praison Praisonaiagents.

How do I fix CVE-2026-40287?

Upgrade praisonaiagents to 1.5.140 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-40287 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40287 exists.

Sources

Also known as GHSA-g985-wjh9-qxxc, PYSEC-2026-2914, PYSEC-2026-2947.

Is CVE-2026-40287 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free