# CVE-2026-40287: PraisonAI has RCE via Automatic tools.py Import

> Attackers can execute arbitrary code by placing a malicious tools.py file in the working directory, affecting PraisonAI users.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-g985-wjh9-qxxc, PYSEC-2026-2914, PYSEC-2026-2947

## What is CVE-2026-40287?

CVE-2026-40287 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Versions 4.5.138 and below are vulnerable to arbitrary code execution through automatic, unsanitized import of a tools.py file from the current working directory. Components including call.py (import_tools_from_file()), tool_resolver.py (_load_local_tools()), and CLI tool-loading paths blindly import ./tools.py at startup without any validation, sandboxing, or user confirmation. An attacker who can place a malicious tools.py in the directory where PraisonAI is launched (such as through a shared project, cloned repository, or writable workspace) achieves immediate arbitrary Python code execution in the host environment. This compromises the full PraisonAI process, the host system, and any connected data or credentials. This issue has been fixed in version 4.5.139.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-40287?

6 open source packages ship an affected version, including praisonaiagents, PraisonAI and praisonai. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `PraisonAI` | PyPI | All versions | 4.5.139 |
| `praisonai` | PyPI | All versions | 4.5.139 |
| `praisonai` | PyPI | All versions | 4.5.139 |

Products: Praison Praisonai, Praison Praisonaiagents.

## How do I fix CVE-2026-40287?

Upgrade praisonaiagents to 1.5.140 or later.

## Is CVE-2026-40287 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40287 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40287 and fix it if it is affected.

What it is: CVE-2026-40287 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40287 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- PraisonAI (PyPI): affected all versions; fixed in 4.5.139
- praisonai (PyPI): affected all versions; fixed in 4.5.139
- praisonai (PyPI): affected all versions; fixed in 4.5.139

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40287/ (Markdown: https://insights.sbomify.com/CVE-2026-40287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40287
- OSV: https://osv.dev/vulnerability/CVE-2026-40287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40287/
Summaries are generated and may contain mistakes; the official description above is the record.
