# CVE-2026-40288: PraisonAI: Critical RCE via `type: job` workflow YAML

> Attackers can execute arbitrary code on the host by supplying malicious YAML workflow files to the PraisonAI library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-vc46-vw85-3wvm, PYSEC-2026-477, PYSEC-2026-488

## What is CVE-2026-40288?

CVE-2026-40288 is a critical code injection vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. In versions below 4.5.139 of PraisonAI and 1.5.140 of praisonaiagents, the workflow engine is vulnerable to arbitrary command and code execution through untrusted YAML files. When praisonai workflow run <file.yaml> loads a YAML file with type: job, the JobWorkflowExecutor in job_workflow.py processes steps that support run: (shell commands via subprocess.run()), script: (inline Python via exec()), and python: (arbitrary Python script execution)—all without any validation, sandboxing, or user confirmation. The affected code paths include action_run() in workflow.py and _exec_shell(), _exec_inline_python(), and _exec_python_script() in job_workflow.py. An attacker who can supply or influence a workflow YAML file (particularly in CI pipelines, shared repositories, or multi-tenant deployment environments) can achieve full arbitrary command execution on the host system, compromising the machine and any accessible data or credentials. This issue has been fixed in versions 4.5.139 of PraisonAI and 1.5.140 of praisonaiagents.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-40288?

6 open source packages ship an affected version, including praisonaiagents, PraisonAI and praisonai. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `PraisonAI` | PyPI | All versions | 4.5.139 |
| `praisonai` | PyPI | All versions | 4.5.139 |
| `praisonai` | PyPI | All versions | 4.5.139 |

Products: Praison Praisonai, Praison Praisonaiagents.

## How do I fix CVE-2026-40288?

Upgrade praisonaiagents to 1.5.140 or later.

## Is CVE-2026-40288 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40288 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)
- [CVE-2026-34935](https://insights.sbomify.com/CVE-2026-34935/): PraisonAI: OS Command Injection in MCPHandler.parse_mcp_command() (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40288 and fix it if it is affected.

What it is: CVE-2026-40288 is a critical code injection vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40288 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- PraisonAI (PyPI): affected all versions; fixed in 4.5.139
- praisonai (PyPI): affected all versions; fixed in 4.5.139
- praisonai (PyPI): affected all versions; fixed in 4.5.139

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40288/ (Markdown: https://insights.sbomify.com/CVE-2026-40288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40288
- OSV: https://osv.dev/vulnerability/CVE-2026-40288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40288/
Summaries are generated and may contain mistakes; the official description above is the record.
