# CVE-2026-40289: PraisonAI Browser Server allows unauthenticated WebSocket clients to hijack connected extension sessions

> Unauthenticated attackers can hijack browser automation sessions in PraisonAI, gaining remote control and accessing sensitive data.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-8x8f-54wf-vv92, PYSEC-2026-467, PYSEC-2026-485

## What is CVE-2026-40289?

CVE-2026-40289 is a critical missing authorization vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. In versions below 4.5.139 of PraisonAI and 1.5.140 of praisonaiagents, the browser bridge (praisonai browser start) is vulnerable to unauthenticated remote session hijacking due to missing authentication and a bypassable origin check on its /ws WebSocket endpoint. The server binds to 0.0.0.0 by default and only validates the Origin header when one is present, meaning any non-browser client that omits the header is accepted without restriction. An unauthenticated network attacker can connect, send a start_session message, and the server will route it to the first idle browser-extension WebSocket (effectively hijacking that session) and then broadcast all resulting automation actions and outputs back to the attacker. This enables unauthorized remote control of connected browser automation sessions, leakage of sensitive page context and automation results, and misuse of model-backed browser actions in any environment where the bridge is network-reachable. This issue has been fixed in versions 4.5.139 of PraisonAI and 1.5.140 of praisonaiagents.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-40289?

6 open source packages ship an affected version, including praisonaiagents, PraisonAI and praisonai. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `praisonaiagents` | PyPI | All versions | 1.5.140 |
| `PraisonAI` | PyPI | All versions | 4.5.139 |
| `praisonai` | PyPI | All versions | 4.5.139 |
| `praisonai` | PyPI | All versions | 4.5.139 |

Products: Praison Praisonai, Praison Praisonaiagents.

## How do I fix CVE-2026-40289?

Upgrade praisonaiagents to 1.5.140 or later.

## Is CVE-2026-40289 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40289 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40289 and fix it if it is affected.

What it is: CVE-2026-40289 is a critical missing authorization vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40289 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.140
- PraisonAI (PyPI): affected all versions; fixed in 4.5.139
- praisonai (PyPI): affected all versions; fixed in 4.5.139
- praisonai (PyPI): affected all versions; fixed in 4.5.139

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40289/ (Markdown: https://insights.sbomify.com/CVE-2026-40289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40289
- OSV: https://osv.dev/vulnerability/CVE-2026-40289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40289/
Summaries are generated and may contain mistakes; the official description above is the record.
