# CVE-2026-40293: OpenFGA Playground Preshared Key Exposure

> Attackers can read the preshared API key from the playground endpoint if exposed, allowing unauthorized access to the authorization service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 9 Sep 2026
- **Also known as:** CLEANSTART-2026-CB09897, GHSA-68m9-983m-f3v5, GO-2026-5170, MINI-29f3-pwmh-57q9, MINI-3fj4-pj3g-fg3m, MINI-4842-93m8-pm74, MINI-4924-7hc6-26wv, MINI-49f8-rgjq-w5h2, MINI-83r9-77rq-2j4v, MINI-8j9v-3m2x-7qm7, MINI-8m4q-6qjp-hqj6, MINI-8v66-mgm3-fr7w, MINI-f437-qhfm-r7vf, MINI-h2j9-pqw3-54f3, MINI-p232-4vcw-99r9, MINI-r49q-hqhj-6q5v, MINI-v24m-v8v4-qpjj, MINI-vcfc-r52c-4528, MINI-w8pr-vx5q-hxm3, MINI-xc6r-qj9m-v999, MINI-xxqf-c23m-3c97

## What is CVE-2026-40293?

CVE-2026-40293 is a medium-severity vulnerability in openfga, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine built for developers. In versions 0.1.4 through 1.13.1, when OpenFGA is configured to use preshared-key authentication with the built-in playground enabled, the local server includes the preshared API key in the HTML response of the /playground endpoint. The /playground endpoint is enabled by default and does not require authentication. It is intended for local development and debugging and is not designed to be exposed to production environments. Only those who run OpenFGA with `--authn-method` preshared, with the playground enabled, and with the playground endpoint accessible beyond localhost or trusted networks are vulnerable. To remediate the issue, users should upgrade to OpenFGA v1.14.0, or disable the playground by running `./openfga run --playground-enabled=false.`

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-40293?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 0.1.4 | 1.14.0 |
| `github.com/openfga/openfga` | Go | From 0.1.4 | 1.14.0 |
| `github.com/openfga/openfga` | Go | From 0.1.4 | 1.14.0 |

Products: Openfga Openfga.

## How do I fix CVE-2026-40293?

Upgrade github.com/openfga/openfga to 1.14.0 or later.

## Is CVE-2026-40293 being exploited?

There is no known exploitation of CVE-2026-40293 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2022-23542](https://insights.sbomify.com/CVE-2022-23542/): OpenFGA Authorization Bypass (high 7.7)
- [CVE-2024-42473](https://insights.sbomify.com/CVE-2024-42473/): OpenFGA Authorization Bypass (high 7.5)
- [CVE-2023-40579](https://insights.sbomify.com/CVE-2023-40579/): OpenFGA Authorization Bypass (medium 6.5)
- [CVE-2023-43645](https://insights.sbomify.com/CVE-2023-43645/): Denial of service from circular relationship definitions in OpenFGA (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40293 and fix it if it is affected.

What it is: CVE-2026-40293 is a medium-severity vulnerability in openfga, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40293 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 0.1.4; fixed in 1.14.0
- github.com/openfga/openfga (Go): affected from 0.1.4; fixed in 1.14.0
- github.com/openfga/openfga (Go): affected from 0.1.4; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40293/ (Markdown: https://insights.sbomify.com/CVE-2026-40293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40293
- OSV: https://osv.dev/vulnerability/CVE-2026-40293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40293/
Summaries are generated and may contain mistakes; the official description above is the record.
