CVE-2026-40295 Devise: Open Redirect via Unvalidated `request.referrer` in Timeoutable Session Timeout Handler

Medium 6.1 Published Updated

Attackers can redirect users with expired sessions to malicious sites via unvalidated referrer headers in Devise's timeout handler, enabling phishing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-40295?

CVE-2026-40295 is a medium-severity vulnerability in heartcombo devise, published on 22 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Devise is an authentication solution for Rails based on Warden. In versions 5.0.3 and below, when the Timeoutable module is enabled in Devise, the FailureApp#redirect_url method returns request.referrer — the HTTP Referer header, which is attacker-controllable — without validation for any non-GET request that results in a session timeout. An attacker who hosts a page with an auto-submitting cross-origin form can cause a victim with an expired Devise session to be redirected to an arbitrary external URL. This contrasts with the GET timeout path (which uses server-side attempted_path) and Devise's own store_location_for mechanism (which strips external hosts via extract_path_from_location), both of which are protected; only the non-GET timeout redirect path is unprotected. Expired-session users can be silently redirected from the trusted app domain to attacker-controlled URLs, enabling phishing and malware delivery while bypassing browser warnings. Note: Rails' built-in open-redirect protection does not mitigate this issue. Devise::FailureApp is an ActionController::Metal app with its own isolated copy of the relevant redirect configuration, so config.action_controller.action_on_open_redirect = :raise (and the older raise_on_open_redirects setting) do not reach it. This issue has been fixed in version 5.0.4.

Weakness: CWE-601

Which versions are affected by CVE-2026-40295?

2 open source packages ship an affected version, including devise. It affects 1 product.

PackageAffectedFixed in
devise RubyGemsAll versions5.0.4
devise RubyGemsAll versions5.0.4

Products include Heartcombo Devise.

How do I fix CVE-2026-40295?

Upgrade devise to 5.0.4 or later.

Is CVE-2026-40295 being exploited?

There is no known exploitation of CVE-2026-40295 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-40295, GHSA-jp94-3292-c3xv, UBUNTU-CVE-2026-40295.

Is CVE-2026-40295 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free