{"answers":{"affected":"2 open source packages ship an affected version, including next-intl.","exploited":"There is no known exploitation of CVE-2026-40299 in the wild and no public exploit code.","fix":"Upgrade next-intl to 4.9.1 or later.","what":"CVE-2026-40299 is a medium-severity vulnerability in amannn next-intl, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40299 and fix it if it is affected.\n\nWhat it is: CVE-2026-40299 is a medium-severity vulnerability in amannn next-intl, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40299 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next-intl (npm): affected all versions; fixed in 4.9.1\n- next-intl (npm): affected all versions; fixed in 4.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40299/ (Markdown: https://insights.sbomify.com/CVE-2026-40299/index.md)","id":"CVE-2026-40299","markdown":"https://insights.sbomify.com/CVE-2026-40299/index.md","name":"CVE-2026-40299","record":{"aliases":["GHSA-8f24-v5vv-gm5j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Next.js i18n library","requires_auth":"none","summary":"Attackers can redirect users to malicious sites via crafted URLs when using specific locale prefix configurations in next-intl middleware.","user_interaction":"not_required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"next-intl provides internationalization for Next.js. Applications using the `next-intl` middleware prior to version 4.9.1with `localePrefix: 'as-needed'` could construct URLs where path handling and the WHATWG URL parser resolved a relative redirect target to another host (e.g. scheme-relative `//` or control characters stripped by the URL parser), so the middleware could redirect the browser off-site while the user still started from a trusted app URL. The problem has been patchedin `next-intl@4.9.1`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"next-intl has an open redirect vulnerability","id":"CVE-2026-40299","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Zulip: Message edit history visible in \"moves only\" policy through /api/v1/messages/{id}/history","id":"CVE-2026-40300"},"packages":[{"ecosystem":"npm","fixed":["4.9.1"],"introduced":["0"],"last_affected":[],"package":"next-intl","purl":null,"source":"GHSA-8f24-v5vv-gm5j"},{"ecosystem":"npm","fixed":["4.9.1"],"introduced":["0"],"last_affected":[],"package":"next-intl","purl":"pkg:npm/next-intl","source":"GHSA-8f24-v5vv-gm5j"}],"prev":{"headline":"PhpSpreadsheet vulnerable to XSS in HTML writer via custom number format codes","id":"CVE-2026-40296"},"products":["next-intl"],"published":"2026-04-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["amannn"]},"summary":"Attackers can redirect users to malicious sites via crafted URLs when using specific locale prefix configurations in next-intl middleware.","url":"https://insights.sbomify.com/CVE-2026-40299/"}