# CVE-2026-40299: next-intl has an open redirect vulnerability

> Attackers can redirect users to malicious sites via crafted URLs when using specific locale prefix configurations in next-intl middleware.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-8f24-v5vv-gm5j

## What is CVE-2026-40299?

CVE-2026-40299 is a medium-severity vulnerability in amannn next-intl, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

next-intl provides internationalization for Next.js. Applications using the `next-intl` middleware prior to version 4.9.1with `localePrefix: 'as-needed'` could construct URLs where path handling and the WHATWG URL parser resolved a relative redirect target to another host (e.g. scheme-relative `//` or control characters stripped by the URL parser), so the middleware could redirect the browser off-site while the user still started from a trusted app URL. The problem has been patchedin `next-intl@4.9.1`.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-40299?

2 open source packages ship an affected version, including next-intl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next-intl` | npm | All versions | 4.9.1 |
| `next-intl` | npm | All versions | 4.9.1 |

## How do I fix CVE-2026-40299?

Upgrade next-intl to 4.9.1 or later.

## Is CVE-2026-40299 being exploited?

There is no known exploitation of CVE-2026-40299 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40299 and fix it if it is affected.

What it is: CVE-2026-40299 is a medium-severity vulnerability in amannn next-intl, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40299 in the wild and no public exploit code.

Affected packages and fixed versions:
- next-intl (npm): affected all versions; fixed in 4.9.1
- next-intl (npm): affected all versions; fixed in 4.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40299/ (Markdown: https://insights.sbomify.com/CVE-2026-40299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40299
- OSV: https://osv.dev/vulnerability/CVE-2026-40299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40299/
Summaries are generated and may contain mistakes; the official description above is the record.
