# CVE-2026-40305: DNN has Force Friend Request Acceptance


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-fpj4-9qhx-5m6m

## What is CVE-2026-40305?

CVE-2026-40305 is a medium-severity vulnerability in Dnnsoftware Dotnetnuke, published on 17 Apr 2026. 

### Official description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 6.0.0 and prior to version 10.2.2, in the friends feature, a user could craft a request that would force the acceptance of a friend request on another user. Version 10.2.2 patches the issue.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-40305?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | From 6.0.0 | 10.2.2 |
| `DotNetNuke.Core` | NuGet | From 6.0.0 | 10.2.2 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2026-40305?

Upgrade DotNetNuke.Core to 10.2.2 or later.

## Is CVE-2026-40305 being exploited?

There is no known exploitation of CVE-2026-40305 in the wild and no public exploit code.

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40305 and fix it if it is affected.

What it is: CVE-2026-40305 is a medium-severity vulnerability in Dnnsoftware Dotnetnuke, published on 17 Apr 2026. 
Exploitation: There is no known exploitation of CVE-2026-40305 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected from 6.0.0; fixed in 10.2.2
- DotNetNuke.Core (NuGet): affected from 6.0.0; fixed in 10.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40305/ (Markdown: https://insights.sbomify.com/CVE-2026-40305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40305
- OSV: https://osv.dev/vulnerability/CVE-2026-40305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40305/
Summaries are generated and may contain mistakes; the official description above is the record.
