# CVE-2026-40315: PraisonAI: SQLiteConversationStore didn't validate table_prefix when constructing SQL queries

> Attackers controlling configuration inputs can inject SQL via table_prefix to read internal SQLite tables and tamper with query results in PraisonAI.

- **Severity:** High 7.2 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-x783-xp3g-mqhp, PYSEC-2026-2925

## What is CVE-2026-40315?

CVE-2026-40315 is a high-severity SQL injection vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to 4.5.133, there is an SQL identifier injection vulnerability in SQLiteConversationStore where the table_prefix configuration value is directly concatenated into SQL queries via f-strings without any validation or sanitization. Since SQL identifiers cannot be safely parameterized, an attacker who controls the table_prefix value (e.g., through from_yaml or from_dict configuration input) can inject arbitrary SQL fragments that alter query structure. This enables unauthorized data access, such as reading internal SQLite tables like sqlite_master, and manipulation of query results through techniques like UNION-based injection. The vulnerability propagates from configuration input in config.py, through factory.py, to the SQL query construction in sqlite.py. Exploitation requires the ability to influence configuration input, and successful exploitation leads to internal schema disclosure and full query result tampering. This issue has been fixed in version 4.5.133.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-40315?

3 open source packages ship an affected version, including praisonai and PraisonAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.5.133 |
| `praisonai` | PyPI | All versions | 4.5.133 |
| `PraisonAI` | PyPI | All versions | 4.5.133 |

Products: Praison Praisonai.

## How do I fix CVE-2026-40315?

Upgrade praisonai to 4.5.133 or later.

## Is CVE-2026-40315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40315 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40315 and fix it if it is affected.

What it is: CVE-2026-40315 is a high-severity SQL injection vulnerability in MervinPraison PraisonAI, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40315 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.5.133
- praisonai (PyPI): affected all versions; fixed in 4.5.133
- PraisonAI (PyPI): affected all versions; fixed in 4.5.133

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40315/ (Markdown: https://insights.sbomify.com/CVE-2026-40315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40315
- OSV: https://osv.dev/vulnerability/CVE-2026-40315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40315/
Summaries are generated and may contain mistakes; the official description above is the record.
