# CVE-2026-40324: Hot Chocolate's Utf8GraphQLParser has Stack Overflow via Deeply Nested GraphQL Documents

> Attackers can crash the GraphQL server process by sending deeply nested documents, causing a stack overflow that terminates the worker.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-qr3m-xw4c-jqw3

## What is CVE-2026-40324?

CVE-2026-40324 is a critical denial of service vulnerability in ChilliCream graphql-platform, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hot Chocolate is an open-source GraphQL server. Prior to versions 12.22.7, 13.9.16, 14.3.1, and 15.1.14, Hot Chocolate's recursive descent parser `Utf8GraphQLParser` has no recursion depth limit. A crafted GraphQL document with deeply nested selection sets, object values, list values, or list types can trigger a `StackOverflowException` on payloads as small as 40 KB. Because `StackOverflowException` is uncatchable in .NET (since .NET 2.0), the entire worker process is terminated immediately. All in-flight HTTP requests, background `IHostedService` tasks, and open WebSocket subscriptions on that worker are dropped. The orchestrator (Kubernetes, IIS, etc.) must restart the process. This occurs before any validation rules run — `MaxExecutionDepth`, complexity analyzers, persisted query allow-lists, and custom `IDocumentValidatorRule` implementations cannot intercept the crash because `Utf8GraphQLParser.Parse` is invoked before validation. The `MaxAllowedFields=2048` limit does not help because the crashing payloads contain very few fields. The fix in versions 12.22.7, 13.9.16, 14.3.1, and 15.1.14 adds a `MaxAllowedRecursionDepth` option to `ParserOptions` with a safe default, and enforces it across all recursive parser methods (`ParseSelectionSet`, `ParseValueLiteral`, `ParseObject`, `ParseList`, `ParseTypeReference`, etc.). When the limit is exceeded, a catchable `SyntaxException` is thrown instead of overflowing the stack. There is no application-level workaround. `StackOverflowException` cannot be caught in .NET. The only mitigation is to upgrade to a patched version. Operators can reduce (but not eliminate) risk by limiting HTTP request body size at the reverse proxy or load balancer layer, though the smallest crashing payload (40 KB) is well below most default body size limits and is highly compressible (~few hundred bytes via gzip).

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-40324?

8 open source packages ship an affected version, including HotChocolate.Language.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `HotChocolate.Language` | NuGet | All versions | 12.22.7 |
| `HotChocolate.Language` | NuGet | All versions | 12.22.7 |
| `HotChocolate.Language` | NuGet | From 13.0.0 | 13.9.16 |
| `HotChocolate.Language` | NuGet | From 13.0.0 | 13.9.16 |
| `HotChocolate.Language` | NuGet | From 14.0.0 | 14.3.1 |
| `HotChocolate.Language` | NuGet | From 14.0.0 | 14.3.1 |
| `HotChocolate.Language` | NuGet | From 15.0.0 | 15.1.14 |
| `HotChocolate.Language` | NuGet | From 15.0.0 | 15.1.14 |

## How do I fix CVE-2026-40324?

Upgrade HotChocolate.Language to a fixed version for your release line: 12.22.7, 13.9.16, 14.3.1 or 15.1.14.

## Is CVE-2026-40324 being exploited?

There is no known exploitation of CVE-2026-40324 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40324 and fix it if it is affected.

What it is: CVE-2026-40324 is a critical denial of service vulnerability in ChilliCream graphql-platform, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40324 in the wild and no public exploit code.

Affected packages and fixed versions:
- HotChocolate.Language (NuGet): affected all versions; fixed in 12.22.7
- HotChocolate.Language (NuGet): affected all versions; fixed in 12.22.7
- HotChocolate.Language (NuGet): affected from 13.0.0; fixed in 13.9.16
- HotChocolate.Language (NuGet): affected from 13.0.0; fixed in 13.9.16
- HotChocolate.Language (NuGet): affected from 14.0.0; fixed in 14.3.1
- HotChocolate.Language (NuGet): affected from 14.0.0; fixed in 14.3.1
- HotChocolate.Language (NuGet): affected from 15.0.0; fixed in 15.1.14
- HotChocolate.Language (NuGet): affected from 15.0.0; fixed in 15.1.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40324/ (Markdown: https://insights.sbomify.com/CVE-2026-40324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40324
- OSV: https://osv.dev/vulnerability/CVE-2026-40324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40324/
Summaries are generated and may contain mistakes; the official description above is the record.
