# CVE-2026-40347: Python-Multipart affected by Denial of Service via large multipart preamble or epilogue data

> Attackers can cause denial of service in applications using Python-Multipart by sending crafted requests with large preamble or epilogue data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** CLEANSTART-2026-IO67375, CLEANSTART-2026-VJ88910, CLSA-2026-1781571262, DEBIAN-CVE-2026-40347, ECHO-93a8-8bc8-dfad, GHSA-mj87-hwqh-73pj, MINI-2mp6-x8g2-xvp4, MINI-98vm-gxc7-7vg7, MINI-9m84-ch59-pqh6, MINI-mhcg-w48q-qh79, MINI-p43r-67hv-fqx3, MINI-r27f-2fcg-x5mq, MINI-w23p-hqhx-5jpj, PYSEC-2026-3038, UBUNTU-CVE-2026-40347, openSUSE-SU-2026:10597-1

## What is CVE-2026-40347?

CVE-2026-40347 is a medium-severity denial of service vulnerability in Kludex python-multipart, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python-Multipart is a streaming multipart parser for Python. Versions prior to 0.0.26 have a denial of service vulnerability when parsing crafted `multipart/form-data` requests with large preamble or epilogue sections. Upgrade to version 0.0.26 or later, which skips ahead to the next boundary candidate when processing leading CR/LF data and immediately discards epilogue data after the closing boundary.

Weakness: CWE-834 (Excessive Iteration), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-40347?

3 open source packages ship an affected version, including python-multipart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-multipart` | PyPI | All versions | 0.0.26 |
| `python-multipart` | PyPI | All versions | 0.0.26 |
| `python-multipart` | PyPI | All versions | 0.0.26 |
| `python-python-multipart` | openSUSE:Tumbleweed | All versions | 0.0.26-1.1 |

Products: Fastapiexpert Python-Multipart.

## How do I fix CVE-2026-40347?

Upgrade python-multipart to 0.0.26 or later.

## Is CVE-2026-40347 being exploited?

There is no known exploitation of CVE-2026-40347 in the wild and no public exploit code.

## Other vulnerabilities in Kludex python-multipart

- [CVE-2026-24486](https://insights.sbomify.com/CVE-2026-24486/): Python-Multipart has Arbitrary File Write via Non-Default Configuration (high 8.6)
- [CVE-2026-53539](https://insights.sbomify.com/CVE-2026-53539/): Python-Multipart: Quadratic-time querystring parsing with semicolon separators causes CPU denial of service (high 7.5)
- [CVE-2024-24762](https://insights.sbomify.com/CVE-2024-24762/): python-multipart vulnerable to content-type header Regular expression Denial of Service (high 7.5)
- [CVE-2026-53537](https://insights.sbomify.com/CVE-2026-53537/): Python-Multipart: Content-Disposition parameter smuggling via RFC 2231/5987 extended parameters (low 3.7)
- [CVE-2026-53538](https://insights.sbomify.com/CVE-2026-53538/): Python-Multipart: Semicolon treated as querystring field separator enables parameter smuggling (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40347 and fix it if it is affected.

What it is: CVE-2026-40347 is a medium-severity denial of service vulnerability in Kludex python-multipart, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40347 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-multipart (PyPI): affected all versions; fixed in 0.0.26
- python-multipart (PyPI): affected all versions; fixed in 0.0.26
- python-multipart (PyPI): affected all versions; fixed in 0.0.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40347/ (Markdown: https://insights.sbomify.com/CVE-2026-40347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40347
- OSV: https://osv.dev/vulnerability/CVE-2026-40347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40347/
Summaries are generated and may contain mistakes; the official description above is the record.
