# CVE-2026-4035: Environment Variable Resolution Vulnerability in mlflow/mlflow

> Attackers can exfiltrate server environment variables via AI Gateway secrets, potentially leading to credential leakage and downstream code execution.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2026
- **Updated:** 14 Aug 2026
- **Also known as:** BIT-mlflow-2026-4035, CLSA-2026-1783904618, CLSA-2026-1787296483, GHSA-g35p-px32-whv6, PYSEC-2026-2222

## What is CVE-2026-4035?

CVE-2026-4035 is a critical vulnerability in Lfprojects Mlflow, published on 3 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in mlflow/mlflow versions prior to 3.11.0 allows for the resolution of environment variables in AI Gateway secrets, which can be exploited to exfiltrate sensitive server-side environment credentials to an attacker-controlled endpoint. This issue arises because the `api_key` field in gateway secrets can accept `$ENV_VAR` references, which are resolved against the MLflow server's environment during runtime. The resolved secrets are then sent in provider authentication headers to the configured upstream `api_base`. This vulnerability can be exploited by low-privileged authenticated users in basic-auth deployments or by unauthenticated users in default deployments without `basic-auth`. The impact includes potential leakage of sensitive credentials such as cloud artifact credentials (`AWS_ACCESS_KEY_ID`, `AWS_SECRET_ACCESS_KEY`), which could lead to artifact poisoning and cross-boundary code execution in downstream environments. The issue is fixed in version 3.11.0.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-4035?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.11.0 |
| `mlflow` | PyPI | All versions | 3.11.0 |
| `mlflow` | PyPI | All versions | 3.11.0 |
| `mlflow` | PyPI | All versions | 3.11.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-4035?

Upgrade mlflow to 3.11.0 or later.

## Is CVE-2026-4035 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4035 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4035 and fix it if it is affected.

What it is: CVE-2026-4035 is a critical vulnerability in Lfprojects Mlflow, published on 3 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4035 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.11.0
- mlflow (PyPI): affected all versions; fixed in 3.11.0
- mlflow (PyPI): affected all versions; fixed in 3.11.0
- mlflow (PyPI): affected all versions; fixed in 3.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4035/ (Markdown: https://insights.sbomify.com/CVE-2026-4035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4035
- OSV: https://osv.dev/vulnerability/CVE-2026-4035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4035/
Summaries are generated and may contain mistakes; the official description above is the record.
