CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636

Critical 9.9 Published Updated

Attackers can inject case-variant headers in JMS, CoAP, or PubSub routes to trigger remote code execution or arbitrary file writes via downstream components.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40453?

CVE-2026-40453 is a critical code injection vulnerability in Apache Camel, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The fix for CVE-2025-27636 added setLowerCase(true) to HttpHeaderFilterStrategy so that case-variant header names such as 'CAmelExecCommandExecutable' are filtered out alongside 'CamelExecCommandExecutable'. The same setLowerCase(true) call was not applied to five non-HTTP HeaderFilterStrategy implementations: JmsHeaderFilterStrategy and ClassicJmsHeaderFilterStrategy in camel-jms, SjmsHeaderFilterStrategy in camel-sjms, CoAPHeaderFilterStrategy in camel-coap, and GooglePubsubHeaderFilterStrategy in camel-google-pubsub. Because those strategies use case-sensitive String.startsWith('Camel'/'camel') filtering while the Camel Exchange stores headers in a case-insensitive map, an attacker with JMS (or equivalent) producer access to the broker consumed by a Camel route can inject case-variant Camel internal headers, which are then resolved by downstream components such as camel-exec and camel-file using their canonical casing. This enables remote code execution and arbitrary file write on routes that forward JMS messages to header-driven components.

This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.2, from 4.19.0 before 4.20.0.

Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.2.

Weakness: CWE-178

Which versions are affected by CVE-2026-40453?

24 open source packages ship an affected version, including org.apache.camel:camel-coap, org.apache.camel:camel-google-pubsub and org.apache.camel:camel-jms. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-coap MavenFrom 3.0.04.14.6
org.apache.camel:camel-coap MavenFrom 3.0.04.14.6
org.apache.camel:camel-coap MavenFrom 4.15.04.18.2
org.apache.camel:camel-coap MavenFrom 4.15.04.18.2
org.apache.camel:camel-coap MavenFrom 4.19.04.20.0
org.apache.camel:camel-coap MavenFrom 4.19.04.20.0
18 more packages
org.apache.camel:camel-google-pubsub MavenFrom 3.0.04.14.6
org.apache.camel:camel-google-pubsub MavenFrom 3.0.04.14.6
org.apache.camel:camel-google-pubsub MavenFrom 4.15.04.18.2
org.apache.camel:camel-google-pubsub MavenFrom 4.15.04.18.2
org.apache.camel:camel-google-pubsub MavenFrom 4.19.04.20.0
org.apache.camel:camel-google-pubsub MavenFrom 4.19.04.20.0
org.apache.camel:camel-jms MavenFrom 3.0.04.14.6
org.apache.camel:camel-jms MavenFrom 3.0.04.14.6
org.apache.camel:camel-jms MavenFrom 4.15.04.18.2
org.apache.camel:camel-jms MavenFrom 4.15.04.18.2
org.apache.camel:camel-jms MavenFrom 4.19.04.20.0
org.apache.camel:camel-jms MavenFrom 4.19.04.20.0
org.apache.camel:camel-sjms MavenFrom 3.0.04.14.6
org.apache.camel:camel-sjms MavenFrom 3.0.04.14.6
org.apache.camel:camel-sjms MavenFrom 4.15.04.18.2
org.apache.camel:camel-sjms MavenFrom 4.15.04.18.2
org.apache.camel:camel-sjms MavenFrom 4.19.04.20.0
org.apache.camel:camel-sjms MavenFrom 4.19.04.20.0

Products include Apache Camel.

How do I fix CVE-2026-40453?

Upgrade org.apache.camel:camel-coap to a fixed version for your release line: 4.14.6, 4.18.2 or 4.20.0.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-40453 being exploited?

There is no known exploitation of CVE-2026-40453 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Camel vulnerabilities

Sources

Also known as CLEANSTART-2026-AM66642, GHSA-jg2m-9x48-3gvj, MINI-2mch-7h58-4h6v, MINI-34v2-xcg4-fxm4, MINI-66j5-8vm7-c8vr, MINI-7g54-92q4-j2f5.

Is CVE-2026-40453 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free