# CVE-2026-40460: NGINX ngx_quic_module vulnerability

> Attackers can spoof source IPs in NGINX HTTP/3 QUIC configurations to bypass authorization and rate limiting controls.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 May 2026
- **Also known as:** ALPINE-CVE-2026-40460, AZL-86847, BELL-CVE-2026-40460, BIT-nginx-2026-40460, BIT-nginx-gateway-2026-40460, DEBIAN-CVE-2026-40460, ECHO-b094-3180-9b8a, GHSA-h7rq-f9gq-mc8r, MINI-43f3-x4g5-x96q, MINI-crxh-h524-c47q, MINI-cxc4-x3j4-7qmm, MINI-fhgc-2gj6-f892, MINI-frhh-rwrh-rxh9, UBUNTU-CVE-2026-40460

## What is CVE-2026-40460?

CVE-2026-40460 is a medium-severity authentication bypass vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When NGINX Plus or NGINX Open Source are configured to use the HTTP/3 QUIC module, an attacker may be able to spoof their source IP address allowing for bypass of authorization or bypass of rate limiting.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-40460?

2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 1.26.0 | 1.30.1 |
| `nginx-gateway` | Bitnami | From 1.26.0 | 1.30.1 |

Products: F5 Dos, F5 Nginx Gateway Fabric, F5 Nginx Ingress Controller, F5 Nginx Instance Manager, F5 Nginx Open Source, F5 Nginx Plus, F5 Waf.

## How do I fix CVE-2026-40460?

Upgrade nginx to 1.30.1 or later.

## Is CVE-2026-40460 being exploited?

There is no known exploitation of CVE-2026-40460 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Open Source

- [CVE-2026-42055](https://insights.sbomify.com/CVE-2026-42055/): NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability (critical 9.2)
- [CVE-2026-42945](https://insights.sbomify.com/CVE-2026-42945/): NGINX ngx_http_rewrite_module vulnerability (critical 9.2)
- [CVE-2026-42946](https://insights.sbomify.com/CVE-2026-42946/): NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerability (high 8.3)
- [CVE-2026-48142](https://insights.sbomify.com/CVE-2026-48142/): NGINX ngx_http_charset_module vulnerability (medium 6.3)
- [CVE-2026-40701](https://insights.sbomify.com/CVE-2026-40701/): NGINX ngx_http_ssl_module vulnerability (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40460 and fix it if it is affected.

What it is: CVE-2026-40460 is a medium-severity authentication bypass vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40460 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 1.26.0; fixed in 1.30.1
- nginx-gateway (Bitnami): affected from 1.26.0; fixed in 1.30.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40460/ (Markdown: https://insights.sbomify.com/CVE-2026-40460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40460
- OSV: https://osv.dev/vulnerability/CVE-2026-40460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40460/
Summaries are generated and may contain mistakes; the official description above is the record.
