CVE-2026-40466 Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection
Authenticated attackers can achieve remote code execution on Apache ActiveMQ brokers by bypassing input validation via HTTP discovery transport.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-40466?
CVE-2026-40466 is a high-severity code injection vulnerability in Apache Activemq, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.
An authenticated attacker may bypass the fix in CVE-2026-34197 by adding a connector using an HTTP Discovery transport via BrokerView.addNetworkConnector or BrokerView.addConnector through Jolokia if the activemq-http module is on the classpath. A malicious HTTP endpoint can return a VM transport through the HTTP URI which will bypass the validation added in CVE-2026-34197. The attacker can then use the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().
This issue affects Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5.
Users are recommended to upgrade to version 5.19.6 or 6.2.5, which fixes the issue.
Which versions are affected by CVE-2026-40466?
13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-all Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-all Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.5 |
activemq Bitnami | All versions | 5.19.6, 6.2.5 |
org.apache.activemq:activemq-broker Maven | All versions | 5.19.6 |
7 more packages
org.apache.activemq:activemq-broker Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.6 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.6 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.5 |
Products include Apache Activemq, Apache Activemq Broker.
How do I fix CVE-2026-40466?
Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.6 or 6.2.5.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-40466 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40466 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-40466, DEBIAN-CVE-2026-40466, GHSA-w3w2-mpp5-92gm, MINI-5q94-4cm7-4j2v, MINI-cqqg-h2pg-fjf6, MINI-frhq-vww8-c28v and 3 more.