# CVE-2026-40466: Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection

> Authenticated attackers can achieve remote code execution on Apache ActiveMQ brokers by bypassing input validation via HTTP discovery transport.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-activemq-2026-40466, DEBIAN-CVE-2026-40466, GHSA-w3w2-mpp5-92gm, MINI-5q94-4cm7-4j2v, MINI-cqqg-h2pg-fjf6, MINI-frhq-vww8-c28v, MINI-x9j5-jh9p-j9v4, ROOT-APP-MAVEN-CVE-2026-40466, UBUNTU-CVE-2026-40466

## What is CVE-2026-40466?

CVE-2026-40466 is a high-severity code injection vulnerability in Apache Activemq, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.

An authenticated attacker may bypass the fix in CVE-2026-34197 by adding a connector using an HTTP Discovery transport via BrokerView.addNetworkConnector or BrokerView.addConnector through Jolokia if the activemq-http module is on the classpath.
A malicious HTTP endpoint can return a VM transport through the HTTP URI which will bypass the validation added in CVE-2026-34197. The attacker can then use the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext.
Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().

This issue affects Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5.

Users are recommended to upgrade to version 5.19.6 or 6.2.5, which fixes the issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-40466?

13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.5 |
| `activemq` | Bitnami | All versions | 5.19.6, 6.2.5 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.5 |

Products: Apache Activemq, Apache Activemq Broker.

## How do I fix CVE-2026-40466?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.6 or 6.2.5.

## Is CVE-2026-40466 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40466 exists.

Public exploit code:

- Apache ActiveMQ - Remote Code Execution via HTTP Discovery Transport Bypass (nuclei): http/cves/2026/CVE-2026-40466.yaml

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40466 and fix it if it is affected.

What it is: CVE-2026-40466 is a high-severity code injection vulnerability in Apache Activemq, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40466 exists.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.5
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.5
- activemq (Bitnami): affected all versions; fixed in 5.19.6, 6.2.5
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.5
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.5
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40466/ (Markdown: https://insights.sbomify.com/CVE-2026-40466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40466
- OSV: https://osv.dev/vulnerability/CVE-2026-40466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40466/
Summaries are generated and may contain mistakes; the official description above is the record.
