{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-40468 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-40468 is a low-severity vulnerability in GNU gawk, published on 13 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40468 and fix it if it is affected.\n\nWhat it is: CVE-2026-40468 is a low-severity vulnerability in GNU gawk, published on 13 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40468 in the wild and no public exploit code.\n\nAffected product: GNU gawk. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40468/ (Markdown: https://insights.sbomify.com/CVE-2026-40468/index.md)","id":"CVE-2026-40468","markdown":"https://insights.sbomify.com/CVE-2026-40468/index.md","name":"CVE-2026-40468","record":{"aliases":["AZL-92289","BELL-CVE-2026-40468","CLSA-2026-1784131550","CLSA-2026-1784802906","DEBIAN-CVE-2026-40468","ECHO-d213-6ca4-3322","GHSA-c5xj-c73w-hcgm","JLSEC-2026-786","SUSE-SU-2026:3211-1","UBUNTU-CVE-2026-40468"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNU gawk utility","requires_auth":"none","summary":"An integer overflow in gawk allows attackers to cause memory exhaustion or execute arbitrary code via heap corruption.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CERT-PL","cpe":[{"product":"gawk","vendor":"fossies"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:L","version":"4.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer overflow vulnerability has been found in \"builtin.c\" program file of gawk. This issue may lead to memory exhaustion on the hosting operating system and could be used to overwrite gawk heap metadata and objects with attacker-controlled bytes. It affects gawk in versions 5.4.0 and below.","ecosystems":["SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Heap buffer overflow in gawk","id":"CVE-2026-40468","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Heap buffer overflow in gawk","id":"CVE-2026-40469"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["4.1.0-5.6.1"],"introduced":["0"],"last_affected":[],"package":"gawk","purl":"pkg:rpm/suse/gawk\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:3211-1"}],"prev":{"headline":"Use after free in gawk","id":"CVE-2026-40467"},"products":["gawk"],"published":"2026-07-13","related":[{"cvss_score":5.1,"headline":"Use after free in gawk","id":"CVE-2026-40467","kev_date_added":null,"published":"2026-07-13"},{"cvss_score":5.1,"headline":"Heap buffer overflow in gawk","id":"CVE-2026-40469","kev_date_added":null,"published":"2026-07-13"},{"cvss_score":5.1,"headline":"Stack-based buffer overflow in gawk","id":"CVE-2026-40553","kev_date_added":null,"published":"2026-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-13","vendors":["GNU"]},"summary":"An integer overflow in gawk allows attackers to cause memory exhaustion or execute arbitrary code via heap corruption.","url":"https://insights.sbomify.com/CVE-2026-40468/"}