# CVE-2026-40470: Hackage package and doc upload stored XSS vulnerability

> Stored XSS in Hackage allows attackers to hijack user sessions via malicious package uploads, enabling unauthorized metadata changes and account takeover.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-hxp4-rf8g-9mwq, HSEC-2024-0004

## What is CVE-2026-40470?

CVE-2026-40470 is a critical cross-site scripting vulnerability in hackage-server, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A critical XSS vulnerability affected hackage-server and
hackage.haskell.org.  HTML and JavaScript files provided in source
packages or via the documentation upload facility were served
as-is on the main hackage.haskell.org domain.  As a consequence,
when a user with latent HTTP credentials browses to the package
pages or documentation uploaded by a malicious package maintainer,
their session can be hijacked to upload packages or
documentation, amend maintainers or other package metadata, or
perform any other action the user is authorised to do.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-40470?

1 open source package ship an affected version, including hackage-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackage-server` | Hackage | From 0.1 | 0.6 |

## How do I fix CVE-2026-40470?

Upgrade hackage-server to 0.6 or later.

## Is CVE-2026-40470 being exploited?

There is no known exploitation of CVE-2026-40470 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40470 and fix it if it is affected.

What it is: CVE-2026-40470 is a critical cross-site scripting vulnerability in hackage-server, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40470 in the wild and no public exploit code.

Affected packages and fixed versions:
- hackage-server (Hackage): affected from 0.1; fixed in 0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40470/ (Markdown: https://insights.sbomify.com/CVE-2026-40470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40470
- OSV: https://osv.dev/vulnerability/CVE-2026-40470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40470/
Summaries are generated and may contain mistakes; the official description above is the record.
