CVE-2026-40476 graphql-php: Denial of Service via quadratic complexity in OverlappingFieldsCanBeMerged validation

Medium 6.9 Published Updated

An attacker can cause excessive CPU usage and denial of service by sending queries with many repeated fields to the graphql-php library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40476?

CVE-2026-40476 is a medium-severity denial of service vulnerability in webonyx graphql-php, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

graphql-go is a Go implementation of GraphQL. In versions 15.31.4 and below, the OverlappingFieldsCanBeMerged validation rule performs O(n²) pairwise comparisons of fields sharing the same response name. An attacker can send a query with thousands of repeated identical fields, causing excessive CPU usage during validation before execution begins. This is not mitigated by existing QueryDepth or QueryComplexity rules. This issue has been fixed in version 15.31.5.

Weakness: CWE-407

Which versions are affected by CVE-2026-40476?

2 open source packages ship an affected version, including webonyx/graphql-php. It affects 1 product.

PackageAffectedFixed in
webonyx/graphql-php PackagistAll versions15.31.5
webonyx/graphql-php PackagistAll versions15.31.5

Products include Webonyx Graphql-Php.

How do I fix CVE-2026-40476?

Upgrade webonyx/graphql-php to 15.31.5 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-40476 being exploited?

There is no known exploitation of CVE-2026-40476 in the wild and no public exploit code.

Sources

Also known as GHSA-68jq-c3rv-pcrr.

Is CVE-2026-40476 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free