{"answers":{"affected":"2 open source packages ship an affected version, including webonyx/graphql-php. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-40476 in the wild and no public exploit code.","fix":"Upgrade webonyx/graphql-php to 15.31.5 or later.","what":"CVE-2026-40476 is a medium-severity denial of service vulnerability in webonyx graphql-php, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40476 and fix it if it is affected.\n\nWhat it is: CVE-2026-40476 is a medium-severity denial of service vulnerability in webonyx graphql-php, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40476 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.31.5\n- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.31.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40476/ (Markdown: https://insights.sbomify.com/CVE-2026-40476/index.md)","id":"CVE-2026-40476","markdown":"https://insights.sbomify.com/CVE-2026-40476/index.md","name":"CVE-2026-40476","record":{"aliases":["GHSA-68jq-c3rv-pcrr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP GraphQL library","requires_auth":"none","summary":"An attacker can cause excessive CPU usage and denial of service by sending queries with many repeated fields to the graphql-php library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"graphql-php","vendor":"webonyx"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"graphql-go is a Go implementation of GraphQL. In versions 15.31.4 and below, the OverlappingFieldsCanBeMerged validation rule performs O(n²) pairwise comparisons of fields sharing the same response name. An attacker can send a query with thousands of repeated identical fields, causing excessive CPU usage during validation before execution begins. This is not mitigated by existing QueryDepth or QueryComplexity rules. This issue has been fixed in version 15.31.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"graphql-php: Denial of Service via quadratic complexity in OverlappingFieldsCanBeMerged validation","id":"CVE-2026-40476","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Improper restriction of the scope of accessible objects in Thymeleaf expressions","id":"CVE-2026-40477"},"packages":[{"ecosystem":"Packagist","fixed":["15.31.5"],"introduced":["0"],"last_affected":[],"package":"webonyx/graphql-php","purl":null,"source":"GHSA-68jq-c3rv-pcrr"},{"ecosystem":"Packagist","fixed":["15.31.5"],"introduced":["0"],"last_affected":[],"package":"webonyx/graphql-php","purl":"pkg:composer/webonyx/graphql-php","source":"GHSA-68jq-c3rv-pcrr"}],"prev":{"headline":"wger has Broken Access Control in the Global Gym Configuration Update Endpoint","id":"CVE-2026-40474"},"products":["graphql-php"],"published":"2026-04-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["webonyx"]},"summary":"An attacker can cause excessive CPU usage and denial of service by sending queries with many repeated fields to the graphql-php library.","url":"https://insights.sbomify.com/CVE-2026-40476/"}