# CVE-2026-40476: graphql-php: Denial of Service via quadratic complexity in OverlappingFieldsCanBeMerged validation

> An attacker can cause excessive CPU usage and denial of service by sending queries with many repeated fields to the graphql-php library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-68jq-c3rv-pcrr

## What is CVE-2026-40476?

CVE-2026-40476 is a medium-severity denial of service vulnerability in webonyx graphql-php, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

graphql-go is a Go implementation of GraphQL. In versions 15.31.4 and below, the OverlappingFieldsCanBeMerged validation rule performs O(n²) pairwise comparisons of fields sharing the same response name. An attacker can send a query with thousands of repeated identical fields, causing excessive CPU usage during validation before execution begins. This is not mitigated by existing QueryDepth or QueryComplexity rules. This issue has been fixed in version 15.31.5.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-40476?

2 open source packages ship an affected version, including webonyx/graphql-php. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webonyx/graphql-php` | Packagist | All versions | 15.31.5 |
| `webonyx/graphql-php` | Packagist | All versions | 15.31.5 |

Products: Webonyx Graphql-Php.

## How do I fix CVE-2026-40476?

Upgrade webonyx/graphql-php to 15.31.5 or later.

## Is CVE-2026-40476 being exploited?

There is no known exploitation of CVE-2026-40476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40476 and fix it if it is affected.

What it is: CVE-2026-40476 is a medium-severity denial of service vulnerability in webonyx graphql-php, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40476 in the wild and no public exploit code.

Affected packages and fixed versions:
- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.31.5
- webonyx/graphql-php (Packagist): affected all versions; fixed in 15.31.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40476/ (Markdown: https://insights.sbomify.com/CVE-2026-40476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40476
- OSV: https://osv.dev/vulnerability/CVE-2026-40476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40476/
Summaries are generated and may contain mistakes; the official description above is the record.
