CVE-2026-40486 Kimai's User Preferences API allows standard users to modify restricted attributes: hourly_rate, internal_rate
Authenticated users can bypass permission checks to modify restricted billing rates, leading to unauthorized financial data tampering.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-40486?
CVE-2026-40486 is a medium-severity missing authorization vulnerability in kimai, published on 17 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kimai is an open-source time tracking application. In versions 2.52.0 and below, the User Preferences API endpoint (PATCH /api/users/{id}/preferences) applies submitted preference values without checking the isEnabled() flag on preference objects. Although the hourly_rate and internal_rate fields are correctly marked as disabled for users lacking the hourly-rate role permission, the API ignores this restriction and saves the values directly. Any authenticated user can modify their own billing rates through this endpoint, resulting in unauthorized financial tampering affecting invoices and timesheet calculations. This issue has been fixed in version 2.53.0.
Weakness: CWE-915
Which versions are affected by CVE-2026-40486?
2 open source packages ship an affected version, including kimai/kimai. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
kimai/kimai Packagist | All versions | 2.53.0 |
kimai/kimai Packagist | All versions | 2.53.0 |
Products include Kimai Kimai.
How do I fix CVE-2026-40486?
Upgrade kimai/kimai to 2.53.0 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-40486 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40486 exists.
Other vulnerabilities in kimai
- CVE-2020-19825 Cross-site Scripting in kimai/kimai
- CVE-2023-53957 Kimai 1.30.10 SameSite Cookie Vulnerability Session Hijacking
- CVE-2021-43515 Improper Neutralization of Formula Elements in a CSV File in Kimai 2
- CVE-2023-46245 Kimai (Authenticated) SSTI to RCE by Uploading a Malicious Twig File
- CVE-2026-23626 Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI)
Sources
Also known as GHSA-qh43-xrjm-4ggp.