# CVE-2026-40488: OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution

> Attackers can upload malicious files with bypassed extensions to achieve remote code execution if server execution restrictions are not configured.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-3j5q-7q7h-2hhv

## What is CVE-2026-40488?

CVE-2026-40488 is a high-severity vulnerability in OpenMage magento-lts, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to version 20.17.0, the product custom option file upload in OpenMage LTS uses an incomplete blocklist (`forbidden_extensions = php,exe`) to prevent dangerous file uploads. This blocklist can be trivially bypassed by using alternative PHP-executable extensions such as `.phtml`, `.phar`, `.php3`, `.php4`, `.php5`, `.php7`, and `.pht`. Files are stored in the publicly accessible `media/custom_options/quote/` directory, which lacks server-side execution restrictions for some configurations, enabling Remote Code Execution if this directory is not explicitly denied script execution. Version 20.17.0 patches the issue.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-40488?

2 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 20.17.0 |
| `openmage/magento-lts` | Packagist | All versions | 20.17.0 |

Products: Openmage Magento.

## How do I fix CVE-2026-40488?

Upgrade openmage/magento-lts to 20.17.0 or later.

## Is CVE-2026-40488 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40488 exists.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)
- [CVE-2020-15244](https://insights.sbomify.com/CVE-2020-15244/): RCE in Magento (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40488 and fix it if it is affected.

What it is: CVE-2026-40488 is a high-severity vulnerability in OpenMage magento-lts, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40488 exists.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.17.0
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40488/ (Markdown: https://insights.sbomify.com/CVE-2026-40488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40488
- OSV: https://osv.dev/vulnerability/CVE-2026-40488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40488/
Summaries are generated and may contain mistakes; the official description above is the record.
