{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40489 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-40489 is a high-severity vulnerability in editorconfig-core-c, published on 18 Apr 2026."},"fix_prompt":"Check this codebase for CVE-2026-40489 and fix it if it is affected.\n\nWhat it is: CVE-2026-40489 is a high-severity vulnerability in editorconfig-core-c, published on 18 Apr 2026. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40489 exists.\n\nAffected product: editorconfig-core-c. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40489/ (Markdown: https://insights.sbomify.com/CVE-2026-40489/index.md)","id":"CVE-2026-40489","markdown":"https://insights.sbomify.com/CVE-2026-40489/index.md","name":"CVE-2026-40489","record":{"aliases":["DEBIAN-CVE-2026-40489","GHSA-97xg-vrcq-254h","OESA-2026-2258","OESA-2026-2259","OESA-2026-2260","SUSE-SU-2026:22125-1","SUSE-SU-2026:2731-1","UBUNTU-CVE-2026-40489","USN-8238-1","USN-8238-2","openSUSE-SU-2026:10663-1","openSUSE-SU-2026:20966-1"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"editorconfig-core-c  is an EditorConfig core library for use by plugins supporting EditorConfig parsing. Versions up to and including 0.12.10 have a stack-based buffer overflow in ec_glob() that allows an attacker to crash any application using libeditorconfig by providing a specially crafted directory structure and .editorconfig file. This is an incomplete fix for CVE-2023-0341. The pcre_str buffer was protected in 0.12.6 but the adjacent l_pattern[8194] stack buffer received no equivalent protection. On Ubuntu 24.04, FORTIFY_SOURCE converts the overflow to SIGABRT (DoS). Version 0.12.11 contains an updated fix.","ecosystems":["SUSE:Linux Enterprise Module for Development Tools 15 SP7","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"editorconfig-core-c has incomplete fix for CVE-2023-0341","id":"CVE-2026-40489","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2026"},"n_packages":5,"n_references":3,"next":{"headline":"AsyncHttpClient leaks authorization credentials to untrusted domains on cross-origin redirects","id":"CVE-2026-40490"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Development Tools 15 SP7","fixed":["0.12.6-150600.3.6.1"],"introduced":["0"],"last_affected":[],"package":"editorconfig-core-c","purl":"pkg:rpm/suse/editorconfig-core-c\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Development%20Tools%2015%20SP7","source":"SUSE-SU-2026:2731-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["0.12.9-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"editorconfig-core-c","purl":"pkg:rpm/suse/editorconfig-core-c\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22125-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["0.12.9-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"editorconfig-core-c","purl":"pkg:rpm/suse/editorconfig-core-c\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22125-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["0.12.9-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"editorconfig-core-c","purl":"pkg:rpm/opensuse/editorconfig-core-c\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20966-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.12.11-1.1"],"introduced":["0"],"last_affected":[],"package":"editorconfig-core-c","purl":"pkg:rpm/opensuse/editorconfig-core-c\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10663-1"}],"prev":{"headline":"OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution","id":"CVE-2026-40488"},"products":["editorconfig-core-c"],"published":"2026-04-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["editorconfig"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-40489/"}