# CVE-2026-40491: gdown Affected by Arbitrary File Write via Path Traversal in gdown.extractall

> Attackers can achieve arbitrary file write and remote code execution by exploiting path traversal in gdown's archive extraction functionality.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-40491, GHSA-76hw-p97h-883f, PYSEC-2026-2158, UBUNTU-CVE-2026-40491

## What is CVE-2026-40491?

CVE-2026-40491 is a medium-severity path traversal vulnerability in wkentaro gdown, published on 18 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

gdown is a Google Drive public file/folder downloader. Versions prior to 5.2.2 are vulnerable to a Path Traversal attack within the extractall functionality. When extracting a maliciously crafted ZIP or TAR archive, the library fails to sanitize or validate the filenames of the archive members. This allow files to be written outside the intended destination directory, potentially leading to arbitrary file overwrite and Remote Code Execution (RCE). Version 5.2.2 contains a fix.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-40491?

3 open source packages ship an affected version, including gdown. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdown` | PyPI | All versions | 5.2.2 |
| `gdown` | PyPI | All versions | 5.2.2 |
| `gdown` | PyPI | All versions | 5.2.2 |

Products: Wkentaro Gdown.

## How do I fix CVE-2026-40491?

Upgrade gdown to 5.2.2 or later.

## Is CVE-2026-40491 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40491 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40491 and fix it if it is affected.

What it is: CVE-2026-40491 is a medium-severity path traversal vulnerability in wkentaro gdown, published on 18 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40491 exists.

Affected packages and fixed versions:
- gdown (PyPI): affected all versions; fixed in 5.2.2
- gdown (PyPI): affected all versions; fixed in 5.2.2
- gdown (PyPI): affected all versions; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40491/ (Markdown: https://insights.sbomify.com/CVE-2026-40491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40491
- OSV: https://osv.dev/vulnerability/CVE-2026-40491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40491/
Summaries are generated and may contain mistakes; the official description above is the record.
