CVE-2026-4053 post edit time limit is not enforced on some post update operations
Authenticated users can bypass post edit time limits to modify file attachments and properties after the allowed window expires.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-4053?
CVE-2026-4053 is a low-severity vulnerability in Mattermost Mattermost Server, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to enforce the PostEditTimeLimit on non-message post fields which allows an authenticated user to modify post file attachments, props, and pin status after the edit window has expired via the post patch and update API endpoints.. Mattermost Advisory ID: MMSA-2026-00631
Weakness: CWE-672
Which versions are affected by CVE-2026-4053?
5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e, 11.5.2+incompatible |
github.com/mattermost/mattermost-server Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e |
github.com/mattermost/mattermost-server Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-4053?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 0.0.0-20260414103857-b21ef302025e, 11.5.2+incompatible or 11.5.2.
Is CVE-2026-4053 being exploited?
There is no known exploitation of CVE-2026-4053 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-hw87-6jcq-9f8q, GO-2026-5442.