# CVE-2026-4053: post edit time limit is not enforced on some post update operations

> Authenticated users can bypass post edit time limits to modify file attachments and properties after the allowed window expires.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-hw87-6jcq-9f8q, GO-2026-5442

## What is CVE-2026-4053?

CVE-2026-4053 is a low-severity vulnerability in Mattermost Mattermost Server, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to enforce the PostEditTimeLimit on non-message post fields which allows an authenticated user to modify post file attachments, props, and pin status after the edit window has expired via the post patch and update API endpoints.. Mattermost Advisory ID: MMSA-2026-00631

Weakness: CWE-672 (Operation on a Resource after Expiration or Release)

## Which versions are affected by CVE-2026-4053?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e, 11.5.2+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e |
| `github.com/mattermost/mattermost-server` | Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.2 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.2 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-4053?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 0.0.0-20260414103857-b21ef302025e, 11.5.2+incompatible or 11.5.2.

## Is CVE-2026-4053 being exploited?

There is no known exploitation of CVE-2026-4053 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4053 and fix it if it is affected.

What it is: CVE-2026-4053 is a low-severity vulnerability in Mattermost Mattermost Server, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4053 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 0.0.0-20250731163400-5b955468ea1e; fixed in 0.0.0-20260414103857-b21ef302025e, 11.5.2+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 0.0.0-20250731163400-5b955468ea1e; fixed in 0.0.0-20260414103857-b21ef302025e
- github.com/mattermost/mattermost-server (Go): affected from 0.0.0-20250731163400-5b955468ea1e; fixed in 0.0.0-20260414103857-b21ef302025e
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.2
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4053/ (Markdown: https://insights.sbomify.com/CVE-2026-4053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4053
- OSV: https://osv.dev/vulnerability/CVE-2026-4053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4053/
Summaries are generated and may contain mistakes; the official description above is the record.
