CVE-2026-4054 Mattermost doesn't validate the response body of proxied images
Remote attackers can cause client-side denial of service by serving malicious SVG files through the image proxy with spoofed Content-Type headers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-4054?
CVE-2026-4054 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 15 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 Fail to validate the response body of proxied images, which allows a remote attacker to enact client-side DoS via an SVG file served from an attacker-controlled origin under a non-SVG Content-Type header (e.g. image/png) embedded in an og:image meta tag or Markdown image link.. Mattermost Advisory ID: MMSA-2026-00630
Weakness: CWE-754
Which versions are affected by CVE-2026-4054?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e, 11.4.4+incompatible, 11.5.2+incompatible |
github.com/mattermost/mattermost-server Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e |
github.com/mattermost/mattermost-server Go | From 0.0.0-20250731163400-5b955468ea1e | 0.0.0-20260414103857-b21ef302025e |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
1 more packages
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-4054?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 0.0.0-20260414103857-b21ef302025e, 11.4.4+incompatible, 11.5.2+incompatible or 11.4.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-4054 being exploited?
There is no known exploitation of CVE-2026-4054 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-j76w-p754-g2w7, GO-2026-5454.