# CVE-2026-4055: Insufficient permission validation on cross-team playbook run creation

> Authenticated users can create playbook runs in unauthorized teams by manipulating team IDs, bypassing permission checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 21 May 2026
- **Also known as:** GHSA-6cfr-wp44-6qmv, GO-2026-5173

## What is CVE-2026-4055?

CVE-2026-4055 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.5.x <= 11.5.1 fail to validate team-level run_create permission against the target team when creating a playbook run which allows an authenticated team member to create runs in teams where they lack permission via specifying a different team ID in the run creation API request. Mattermost Advisory ID: MMSA-2026-00629

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-4055?

6 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20260304132957-9f2616376582 | 8.0.0-20260320113102-f2b3d1c6a945 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20260304132957-9f2616376582 | 8.0.0-20260320113102-f2b3d1c6a945 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20260304132957-9f2616376582 | 8.0.0-20260320113102-f2b3d1c6a945 |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-4055?

Upgrade github.com/mattermost/mattermost/server/v8 to 8.0.0-20260320113102-f2b3d1c6a945 or later.

## Is CVE-2026-4055 being exploited?

There is no known exploitation of CVE-2026-4055 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4055 and fix it if it is affected.

What it is: CVE-2026-4055 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4055 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20260304132957-9f2616376582; fixed in 8.0.0-20260320113102-f2b3d1c6a945
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20260304132957-9f2616376582; fixed in 8.0.0-20260320113102-f2b3d1c6a945
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20260304132957-9f2616376582; fixed in 8.0.0-20260320113102-f2b3d1c6a945
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4055/ (Markdown: https://insights.sbomify.com/CVE-2026-4055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4055
- OSV: https://osv.dev/vulnerability/CVE-2026-4055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4055/
Summaries are generated and may contain mistakes; the official description above is the record.
